Bug #51170 Error after selected "Home" tab in MySQL Workbench 5.2.15
Submitted: 14 Feb 2010 10:10 Modified: 15 Feb 2010 13:04
Reporter: Powal Yura Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.15 OS:Microsoft Windows (Seven 32bit Russian Ultimate)
Assigned to: CPU Architecture:Any

[14 Feb 2010 10:10] Powal Yura
Description:
Exception = System.ArgumentOutOfRangeException
Message = Индекс за пределами диапазона. Индекс должен быть положительным числом, а его размер не должен превышать размер коллекции.
Имя параметра: index
FullText = System.ArgumentOutOfRangeException: Индекс за пределами диапазона. Индекс должен быть положительным числом, а его размер не должен превышать размер коллекции.
Имя параметра: index
   в System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
   в System.ThrowHelper.ThrowArgumentOutOfRangeException()
   в System.Collections.Generic.List`1.get_Item(Int32 index)
   в System.Collections.ObjectModel.ReadOnlyCollection`1.get_Item(Int32 index)
   в MySQL.GUI.Workbench.MainForm.mainDockPanel_ActiveDocumentChanged(Object sender, EventArgs e)
   в WeifenLuo.WinFormsUI.Docking.DockPanel.OnActiveDocumentChanged(EventArgs e)
   в WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.RefreshActiveWindow()
   в WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.HookEventHandler(Object sender, HookEventArgs e)
   в WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.LocalWindowsHook.OnHookInvoked(HookEventArgs e)
   в WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.LocalWindowsHook.CoreHookProc(Int32 code, IntPtr wParam, IntPtr lParam)
   в WeifenLuo.WinFormsUI.Docking.NativeMethods.CallNextHookEx(IntPtr hhook, Int32 code, IntPtr wParam, IntPtr lParam)
   в WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.LocalWindowsHook.CoreHookProc(Int32 code, IntPtr wParam, IntPtr lParam)
   в WeifenLuo.WinFormsUI.Docking.NativeMethods.CallNextHookEx(IntPtr hhook, Int32 code, IntPtr wParam, IntPtr lParam)
   в WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.LocalWindowsHook.CoreHookProc(Int32 code, IntPtr wParam, IntPtr lParam)
   в System.Windows.Forms.UnsafeNativeMethods.SetFocus(HandleRef hWnd)
   в System.Windows.Forms.ContainerControl.FocusActiveControlInternal()
   в System.Windows.Forms.ContainerControl.SetActiveControlInternal(Control value)
   в System.Windows.Forms.ContainerControl.SetActiveControl(Control ctl)
   в System.Windows.Forms.ContainerControl.set_ActiveControl(Control value)
   в System.Windows.Forms.Control.Select(Boolean directed, Boolean forward)
   в System.Windows.Forms.Control.SelectNextControl(Control ctl, Boolean forward, Boolean tabStopOnly, Boolean nested, Boolean wrap)
   в System.Windows.Forms.Control.SelectNextControlInternal(Control ctl, Boolean forward, Boolean tabStopOnly, Boolean nested, Boolean wrap)
   в System.Windows.Forms.Control.SelectNextIfFocused()
   в System.Windows.Forms.Control.SetVisibleCore(Boolean value)
   в System.Windows.Forms.Form.SetVisibleCore(Boolean value)
   в System.Windows.Forms.Control.set_Visible(Boolean value)
   в WeifenLuo.WinFormsUI.Docking.DockContentHandler.SetVisible()
   в WeifenLuo.WinFormsUI.Docking.DockPane.set_ActiveContent(IDockContent value)
   в WeifenLuo.WinFormsUI.Docking.DockPaneStripBase.OnMouseDown(MouseEventArgs e)
   в System.Windows.Forms.Control.WmMouseDown(Message& m, MouseButtons button, Int32 clicks)
   в System.Windows.Forms.Control.WndProc(Message& m)
   в WeifenLuo.WinFormsUI.Docking.DockPaneStripBase.WndProc(Message& m)
   в System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   в System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   в System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
go to EER Diagram and open for editing any table for table
return to home tab
[15 Feb 2010 13:04] Johannes Taxacher
This is a duplicate of bug #50768