Bug #51123 WorkBench crashes when closing connection tab
Submitted: 11 Feb 2010 21:59 Modified: 26 Apr 2010 17:04
Reporter: Bob Dankert Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.16 OS:Microsoft Windows (Win 7 64)
Assigned to: CPU Architecture:Any

[11 Feb 2010 21:59] Bob Dankert
Description:
If I open a connection in WorkBench and close the tab quickly after opening the connection, WorkBench will crash.  The error details from the event log are:

Faulting application name: MySQLWorkbench.exe, version: 5.2.15.5053, time stamp: 0x4b69b797
Faulting module name: wbpublic.be.dll, version: 0.0.0.0, time stamp: 0x4b69b26a
Exception code: 0xc0000005
Fault offset: 0x0009b7fa
Faulting process id: 0x%9
Faulting application start time: 0x%10
Faulting application path: %11
Faulting module path: %12
Report Id: %13

How to repeat:
Open a connection and close it right away.

Suggested fix:
Don't crash :)
[11 Feb 2010 22:00] Bob Dankert
Additionally, if needed I can run a debug on this to provide additional information.  I have made it crash at least 10-15 times, so I know I can replicate the issue at will.

Bob
[12 Feb 2010 12:00] Johannes Taxacher
not able to reproduce on my box (win7 x64), sounds like a race condition though.
[12 Feb 2010 17:45] Bob Dankert
I should add that the connection is to a remotely located database and the database is large, so fetching the table information takes a few seconds.  It seems to be that closing the tab while the data is still fetching is what causes the problem.  I can still replicate this at will, so if any debugging of the issue is required please let me know.
[19 Feb 2010 11:28] Susanne Ebrecht
Is there something interesting in server error log?
[19 Feb 2010 14:42] Bob Dankert
Nope, nothing in the log actually.  I don't know why there would be, though, given that this is a problem with coding on the client.  I agree with Johannes that this sounds very much like a race condition exists.
[29 Mar 2010 18:29] MySQL Verification Team
Please try 5.2.16 and according the steps you do to hit the crash could be a duplicate bug report. Thanks in advance.
[29 Mar 2010 19:07] Bob Dankert
Yes, this is still happening in 5.2.16.  It is very easy to reproduce, just open a new tab, and while it is still loading click the close tab button.  Here are the error details of the crash in 5.2.16 from windows event log:

Fault bucket 1725167524, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: MySQLWorkbench.exe
P2: 5.2.16.5249
P3: 4b7b0da4
P4: wbpublic.be.dll
P5: 0.0.0.0
P6: 4b7b0754
P7: c0000005
P8: 0009b22a
P9: 
P10:
[25 Apr 2010 16:00] Sveta Smirnova
Thank you for the feedback.

Please try with current version 5.2.19 and if problem still exists provide more information about how you connect to the servers: are they local or remote, do you use specific connect options?
[26 Apr 2010 14:12] Bob Dankert
I beleive this is now fixed in 5.2.19 as I cannot reproduce it anymore.  The connections were remote, SSL and compression enabled, but that shouldn't matter anymore.  Thanks!

Bob Dankert
[26 Apr 2010 17:04] Sveta Smirnova
Thank you for the feedback.

Closing as "Can't repeat" because last comment.