Bug #51117 AccessViolationException
Submitted: 11 Feb 2010 18:42 Modified: 8 Mar 2010 13:43
Reporter: David Nielson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version: OS:Microsoft Windows (Win7 64-bit)
Assigned to: CPU Architecture:Any

[11 Feb 2010 18:42] David Nielson
Description:
Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at Sql_editor.check_sql(Sql_editor* , shared_ptr<Sql_editor>* , Boolean )
   at MySQL.Grt.Db.Sql.Sql_editor.check_sql()
   at MySQL.Grt.Db.Sql.SqlEditor.CheckSyntax()
   at MySQL.Grt.Db.Sql.SqlEditor.BackgroundActionTimer(Object obj, EventArgs args)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Open workbench...it will crash.
[12 Feb 2010 11:53] Johannes Taxacher
Hi David,

we'd need a few more information on this. first, what WB version is causing the troubles?
Did this crash happen from the very start of using WB - right after installing - or were you able to run it and the crash happens now after some use?
[8 Mar 2010 13:43] Sergei Tkachenko
Duplicate of the bug #51815