Bug #51078 Server crashed while allocating memory
Submitted: 11 Feb 2010 2:03 Modified: 13 Mar 2014 19:05
Reporter: Elena Stepanova Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.5.99-m3-debug OS:Any
Assigned to: CPU Architecture:Any

[11 Feb 2010 2:03] Elena Stepanova
Description:
100209  2:34:38 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=25165824
read_buffer_size=131072
max_used_connections=35
max_threads=120
thread_count=35
connection_count=34
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 71894 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x2aaabc0f19a0

thd->query at 0x23bb760 = CREATE INDEX f1_index USING BTREE ON GVLSGYEX (f1)
thd->thread_id=85
thd->killed=NOT_KILLED

#0  0x00002b244b9a2ea3 in pthread_kill () from /lib64/libpthread.so.0
#1  0x00000000009efba2 in my_write_core (sig=11) at stacktrace.c:326
#2  0x000000000062eedd in handle_segfault (sig=11) at mysqld.cc:2726
#3  <signal handler called>
#4  0x00002b244c0831d4 in _int_malloc () from /lib64/libc.so.6
#5  0x00002b244c084766 in malloc () from /lib64/libc.so.6
#6  0x00000000009d34d9 in my_malloc (size=992, my_flags=1040) at my_malloc.c:34
#7  0x00000000009d4350 in alloc_root (mem_root=0x2aaabf08f290, length=400) at my_alloc.c:201
#8  0x000000000053c5a9 in Sql_alloc::operator new (size=400, mem_root=0x2aaabf08f290) at ../../sql/sql_list.h:45
#9  0x000000000096b808 in myisam_create_handler (hton=0xfb9730, table=0x2aaabf08f390, mem_root=0x2aaabf08f290) at ha_myisam.cc:127
#10 0x00000000007845c2 in get_new_handler (share=0x2aaabf08f390, alloc=0x2aaabf08f290, db_type=0xfb9730) at handler.cc:252
#11 0x00000000006a7368 in open_table_from_share (thd=0x2aaabc0f19a0, share=0x2aaabf08f390, alias=0x23bb888 "GVLSGYEX", db_stat=39, prgflag=44, 
    ha_open_flags=0, outparam=0x2aaabf08eac0, is_create_table=false) at table.cc:1675
#12 0x000000000069aba4 in open_unireg_entry (thd=0x2aaabc0f19a0, entry=0x2aaabf08eac0, table_list=0x23bb898, alias=0x23bb888 "GVLSGYEX", 
    cache_key=0x44b51dc0 "systest2", cache_key_length=18, mem_root=0x44b52010, flags=0) at sql_base.cc:3949
#13 0x000000000069d392 in open_table (thd=0x2aaabc0f19a0, table_list=0x23bb898, mem_root=0x44b52010, refresh=0x44b5208f, flags=0)
    at sql_base.cc:2946
#14 0x000000000069e23f in open_tables (thd=0x2aaabc0f19a0, start=0x44b520f0, counter=0x44b52124, flags=0) at sql_base.cc:4621
#15 0x000000000069eb2f in open_and_lock_tables_derived (thd=0x2aaabc0f19a0, tables=0x23bb898, derived=false) at sql_base.cc:5027
#16 0x000000000064c5aa in simple_open_n_lock_tables (thd=0x2aaabc0f19a0, tables=0x23bb898) at mysql_priv.h:1580
#17 0x000000000069ecef in open_n_lock_single_table (thd=0x2aaabc0f19a0, table_l=0x23bb898, lock_type=TL_WRITE_ALLOW_READ) at sql_base.cc:4905
#18 0x00000000007a5d8f in mysql_alter_table (thd=0x2aaabc0f19a0, new_db=0x23bbbf0 "systest2", new_name=0x23bb850 "GVLSGYEX", 
    create_info=0x44b536d0, table_list=0x23bb898, alter_info=0x44b53ff0, order_num=0, order=0x0, ignore=false) at sql_table.cc:6568
#19 0x0000000000641303 in mysql_execute_command (thd=0x2aaabc0f19a0) at sql_parse.cc:2623
#20 0x00000000006489ef in mysql_parse (thd=0x2aaabc0f19a0, inBuf=0x23bb760 "CREATE INDEX f1_index USING BTREE ON GVLSGYEX (f1)", length=50, 
    found_semicolon=0x44b54f80) at sql_parse.cc:5985
#21 0x0000000000649f7d in dispatch_command (command=COM_QUERY, thd=0x2aaabc0f19a0, 
    packet=0x2aaabc0f42f1 "CREATE INDEX f1_index USING BTREE ON GVLSGYEX (f1)", packet_length=50) at sql_parse.cc:1143
#22 0x000000000064b324 in do_command (thd=0x2aaabc0f19a0) at sql_parse.cc:813
#23 0x000000000063854b in do_handle_one_connection (thd_arg=0x2aaabc0f19a0) at sql_connect.cc:1174
#24 0x0000000000638601 in handle_one_connection (arg=0x2aaabc0f19a0) at sql_connect.cc:1113
#25 0x00002b244b99e143 in start_thread () from /lib64/libpthread.so.0
#26 0x00002b244c0d68cd in clone () from /lib64/libc.so.6
#27 0x0000000000000000 in ?? ()

How to repeat:
No repeatable test case so far
[13 Mar 2014 19:05] Sveta Smirnova
Closed as "Can't repeat", because I have not access to files provided anymore, error was sporadic and what caused it to happen is unknown. If you are able to repeat similar failure feel free to reopen the report.