Bug #51036 Attepted to read or write protected memory
Submitted: 9 Feb 2010 17:30 Modified: 8 Mar 2010 13:41
Reporter: Jeremy Wilson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.15.5053 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[9 Feb 2010 17:30] Jeremy Wilson
Description:
Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at Sql_editor.check_sql(Sql_editor* , shared_ptr<Sql_editor>* , Boolean )
   at MySQL.Grt.Db.Sql.Sql_editor.check_sql()
   at MySQL.Grt.Db.Sql.SqlEditor.CheckSyntax()
   at MySQL.Grt.Db.Sql.SqlEditor.BackgroundActionTimer(Object obj, EventArgs args)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Pasting large sql into sql editor; intermittent issue.
[9 Feb 2010 18:19] Valeriy Kravchuk
How large that SQL should be? 1K, 100K, 1M of text?
[8 Mar 2010 13:41] Sergei Tkachenko
Duplicate of the bug #51815