Bug #51030 MySQL Workbench has encountered a problem
Submitted: 9 Feb 2010 15:56 Modified: 9 Feb 2010 17:22
Reporter: Simon Duggan Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2.15 Beta 5053 OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[9 Feb 2010 15:56] Simon Duggan
Description:
I was busy creating multiple EER diagrams.  When I clicked on the home tab, I had the 'MySQL Workbench has encountered a problem' dialog popup.  So not sure what caused it, but here is the info from the dialog.

Exception = System.ArgumentOutOfRangeException
Message = Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
FullText = System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
   at System.ThrowHelper.ThrowArgumentOutOfRangeException()
   at System.Collections.Generic.List`1.get_Item(Int32 index)
   at System.Collections.ObjectModel.ReadOnlyCollection`1.get_Item(Int32 index)
   at MySQL.GUI.Workbench.MainForm.mainDockPanel_ActiveDocumentChanged(Object sender, EventArgs e)
   at WeifenLuo.WinFormsUI.Docking.DockPanel.OnActiveDocumentChanged(EventArgs e)
   at WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.RefreshActiveWindow()
   at WeifenLuo.WinFormsUI.Docking.DockPanel.FocusManagerImpl.ResumeFocusTracking()
   at WeifenLuo.WinFormsUI.Docking.DockPanel.ResumeLayout(Boolean performLayout, Boolean allWindows)
   at WeifenLuo.WinFormsUI.Docking.DockPane.CloseContent(IDockContent content)
   at WeifenLuo.WinFormsUI.Docking.DockPane.CloseActiveContent()
   at WeifenLuo.WinFormsUI.Docking.VS2005DockPaneStrip.Close_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Creating multiple EER diagrams.  
Click on the home tab.
[9 Feb 2010 17:22] Valeriy Kravchuk
Looks like a duplicate of Bug #50980.