Bug #50967 AccessViolationException in Workbench SQL editor
Submitted: 6 Feb 2010 22:24 Modified: 8 Mar 2010 13:40
Reporter: Christoph Vanthuyne Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2 latest beta OS:Microsoft Windows (7 x64)
Assigned to: CPU Architecture:Any

[6 Feb 2010 22:24] Christoph Vanthuyne
Description:
Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at Sql_editor.check_sql(Sql_editor* , shared_ptr<Sql_editor>* , Boolean )
   at MySQL.Grt.Db.Sql.Sql_editor.check_sql()
   at MySQL.Grt.Db.Sql.SqlEditor.CheckSyntax()
   at MySQL.Grt.Db.Sql.SqlEditor.BackgroundActionTimer(Object obj, EventArgs args)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
had invalid sql statement at beginning of script

set session sql_mode='ANSI';

tried to remove the quotes
[7 Feb 2010 2:05] Miguel Solorzano
Thank you for the bug report. Could you please describe step by step how to repeat? I didn't understand how to repeat instructions. Thanks in advance.
[9 Feb 2010 10:38] Susanne Ebrecht
Many thanks for writing a bug report.

For making a deeper analysis we would need to know how to produce this.

Is it related to ANSI mode? Are there trouble with " instead of backticks?
[8 Mar 2010 13:40] Sergei Tkachenko
Duplicate of the bug #51815