Bug #50955 WB SQL Editor hanging when applying sql script from the live table edit tab
Submitted: 5 Feb 2010 19:50 Modified: 8 Feb 2010 9:42
Reporter: Evandro Moreno Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:5.2.15 Beta revision 5053 OS:Mac OS X (10.6.2)
Assigned to: CPU Architecture:Any
Tags: Commit Script, Edit Data, sql editor

[5 Feb 2010 19:50] Evandro Moreno
Description:
After editing table data at the live table edit tab and clicking on the "Save Edited Table Data" button a confirmation pop-up window opens asking for the user to revise the sql script. When on clicks on the "Apply SQL Script" button at the right bottom corner of the screen the application hangs indefinitely.

However, after copying the script from the revision window to the main script tab and running the script the changes are applied with no problems.

How to repeat:
Just add anything in a table at the live table edit tab and them try to apply the script using the green button at the right bottom of the window.

Suggested fix:
Instead of keeping the script on the background, show the script that applies the changes directly at the main script window. Add a confirmation request to the onclick behavior of the run script button. Users may revise the script directly at the main script tab.
[6 Feb 2010 11:18] Valeriy Kravchuk
Thank you for the bug report. Verified just as described.
[8 Feb 2010 9:42] Sergei Tkachenko
Duplicate of the bug #50920. It's common for Linux and OS X platforms.