Bug #50880 ~/.my.cnf is not processed
Submitted: 3 Feb 2010 13:59 Modified: 3 Feb 2010 16:10
Reporter: Alexander Barkov Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:mysql-next-mr OS:Linux (Fedora)
Assigned to: Marc Alff CPU Architecture:Any

[3 Feb 2010 13:59] Alexander Barkov
Description:
~/.my.cnf is not loaded in the latest mysql-next-mr.

How to repeat:
Put .my.cnf in the home directory with some non-default
options in [mysqld] section. For example,

[mysqld]
port=3307

Then try to start mysqld.

I get this error:

100203 17:51:04 [ERROR] Do you already have another mysqld server running on port: 3306 ?

(Yes, I also have a "standard" server running on the port 3306
 which I installed with the system)

Suggested fix:
Restore the old behaviour, to process ~/.my.cnf again.
[3 Feb 2010 14:07] Alexander Barkov
Note, I tried "strace mysqld" with both working and non-working versions:

strace ./mysqld 2>&1 |grep /.my.cnf

A working version reports:

stat64("/home/bar/.my.cnf", {st_mode=S_IFREG|0600, st_size=2062, ...}) = 0
open("/home/bar/.my.cnf", O_RDONLY|O_LARGEFILE) = 3

A non-working version reports:

stat64("~/.my.cnf", 0xbf9ee0f4)         = -1 ENOENT (No such file or directory)

File names passed to stat64() system call are different.
But I thought stat64() supports both notations.
[3 Feb 2010 14:57] Valeriy Kravchuk
I think this is closely related to (or a duplicate of) bug #50337. Please, check.
[3 Feb 2010 15:33] Alexander Barkov
Valeriy, you're right, looks very related to bug#50337.
But I am not 100% sure. I think we need to ask Marc.
[3 Feb 2010 16:10] Marc Alff
Duplicate of Bug#50337