Bug #50635 OS Language small problem - Server Administration
Submitted: 26 Jan 2010 19:10 Modified: 15 Feb 2010 17:12
Reporter: Pedro Perea Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.14 Beta OS:Microsoft Windows (4990)
Assigned to: Alfredo Kojima CPU Architecture:Any
Tags: Server Administration - new Server Instance

[26 Jan 2010 19:10] Pedro Perea
Description:
When trying to create a new Server Instance, cannot found the my.ini file because the variable %Program files does not contain the right value for non-English Windows instalations (in this case "Archivos de Programa" instead of "Program Files").

How to repeat:
Install MySql and MySql Workbench in a non-english Windows machine, try to create a Server Instance.

Suggested fix:
Take present the OS language.
[26 Jan 2010 19:16] MySQL Verification Team
Thank you for the bug report. Are you reporting a Workbench bug right?. I am changing the Category otherwise please let me know. Thanks in advance.
[27 Jan 2010 7:44] Pedro Perea
Yes it is. Workbench bug.
Thanks
[27 Jan 2010 10:05] Johannes Taxacher
Hello Pedro,

these values are just template values for default installations and need to be adapted in most cases anyway. This is why you get to change this setting further down in the wizard in a separate step.
[27 Jan 2010 16:47] MySQL Verification Team
Verified on XP Portuguese Version.
[28 Jan 2010 12:09] Mike Lischke
Fixed in 5.2.
[8 Feb 2010 15:13] Johannes Taxacher
Bug #50966 has been marked as duplicate of this one
[8 Feb 2010 15:28] Johannes Taxacher
Bug #50873 has been marked as duplicate of this one
[8 Feb 2010 19:28] Alfredo Kojima
The following changes have been made to address this issue:
- 3 new templates for Windows have been added. They're intended to be used in 64 bit Windows machines running 32bit MySQL server.
- Paths containing %ProgramFiles% and %ProgramFiles(x86)% variables are expanded in the Administration module
[9 Feb 2010 13:43] Johannes Taxacher
Bug #51008 has been marked as duplicate of this one
[10 Feb 2010 13:42] Tony Freixas
This bug occurs in my English version of Windows, so I don't think it has anything to do with Windows is in English or not.

This bug still exists in the 5.2.15 Beta. Could you please specify the version in which this will be fixed?

The user interface is problematic. When I encountered this error, I thought I couldn't proceed. As I researched it, I found some other people who had the same reaction. Finally, someone pointed out that I could ignore this error and continue. This is not obvious. The error message should probably say "Warning", not "Error" and it should indicate that you can specify the exact location in a later step.
[12 Feb 2010 23:28] Johannes Taxacher
fixed in repository
[15 Feb 2010 17:12] Tony Bedford
See also bug #50050. Also noted duplicates: #50966, #50873, #51008.

Changelog for 5.2.16 updated.