Bug #50426 Support functional field defaults
Submitted: 18 Jan 2010 19:47 Modified: 19 Jan 2010 9:40
Reporter: Olaf van der Spek (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: DDL Severity:S4 (Feature request)
Version:* OS:Any
Assigned to:
Tags: qc

[18 Jan 2010 19:47] Olaf van der Spek
Description:
Currently only constants can be used as column defaults. Could you add support for functional defaults?
That way I could for example set the default to unix_timestamp(), which would get evaluated when needed.

How to repeat:
-
[19 Jan 2010 4:48] Valerii Kravchuk
I think this is a duplicate of Bug#12707. Please, check.
[19 Jan 2010 9:23] Olaf van der Spek
Yep
[19 Jan 2010 9:40] Valerii Kravchuk
Duplicate of Bug#12707.