Bug #50216 MySQL Workbench crashes on startup (Windows 7 64bit Ultimate)
Submitted: 10 Jan 2010 19:40 Modified: 26 May 2011 16:18
Reporter: Robert Hieger Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.11 OSS beta, 5.2.33b OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[10 Jan 2010 19:40] Robert Hieger
Description:
Using Windows 7 Ultimate Edition with 64bit edition of MySQL Server, startup of MySQL Workbench 5.2.11 OSS beta crashes on startup with the following error message:

CLR error: 80004005  The program will now terminate.

I checked the logged bug reports and have not found a similar instance. Please forgive me if this is a duplicate entry.

Any assistance greatly appreciated.

Sincerely,

Robert Hieger

How to repeat:
From start icon using Windows 7 Ultimate Edition 64 bits, go to All Programs and click on icon for MySQL Workbench.

Crash happens immediately after click on this icon.
[11 Jan 2010 11:20] Johannes Taxacher
Hi Robert,

did you have a previous version of MySQL Workbench installed on the machine before installing the 5.2.11 release?. Please try to delete the following directory and check if WB then starts correctly: C:\Users\<yourusername>\AppData\Roaming\MySQL\Workbench
[11 Jan 2010 21:13] Robert Hieger
Hi Johannes,

Many thanks for your quick response. I was about to look into deleting the directory you specified, but then suddenly WB decided to work for no apparent reason.

Several restarts of the machine did not accomplish this prior to this attempt.

I will keep a close watch on this and let you know if the problem re-occurs.

Again, many thanks for your help.

Sincerely,

Robert Hieger
[13 Feb 2010 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[12 May 2010 19:39] Iande Coutinho
Same thing happening here, for both 5.2 and 5.1. On windows 7 PRO 64bits
[20 Jun 2010 9:41] nicolas diogo
Hi,

i was having the same problem.

but also had problem when workbench started but could not create any connection to remote servers -only localhost.

it has been fixed after deleting the mentioned folder from Windows 7 x64 Ultimate (or is it?).

thanks for the great tool
[4 Apr 2011 23:28] jon lee
I get the same things when I try to start on Win7 64bit.  I have only .NET Framework 4 installed.  No previous .NET Runtime versions are installed.

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLWorkbench.exe
  Application Version:	5.2.33.7508
  Application Timestamp:	4d820632
  Fault Module Name:	atioglxx.dll
  Fault Module Version:	6.14.10.9236
  Fault Module Timestamp:	4b2aa66c
  Exception Code:	c0000005
  Exception Offset:	0000b212
  OS Version:	6.1.7600.2.0.0.256.1
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789
[5 Apr 2011 15:52] Valeriy Kravchuk
What videocard do you have on this machine?
[5 Apr 2011 16:12] jon lee
I have an ATI Radeon Mobility 5870 HD... I am using the latest ASUS drivers as the Catalyst drivers won't work on this machine...  It's an ASUS G73-JH.

I'll have to spend some time with some driver cleaners and try to get a clean version of catalyst running successfully.

FYI - I tried launching workbench using the -swrendering switch, but that didn't seem to help either.

Hope this little bit of info helps..  If there's a dev build with a possible fix, please let me know.  I can try and QA this issue for your folks.  For now, I am remembering how to do my FK Constraints by hand.. >:D

Thanks,

Jon
[6 Apr 2011 19:45] Marcelo da Silva Monteiro
i had upgraded it to 5.2.33b version and it´s still crashing on startup running on Windows 7 Ultimate PT-BR SP1 version + 945GC + C2D-E4600 + 4GB DDR2-667
[6 Apr 2011 19:47] Marcelo da Silva Monteiro
Complement error info:
Error on .NET Framework [7614] instruction
[18 Apr 2011 13:18] Becky D
I too have the problem.  I can launch MySQL Workbench and it will run for awhile.  However, once I start a backup job, MySQL Workbench crashes and no longer works.  I also have Windows 7 64 bit - Dell Latitude E6410 machine.
[10 May 2011 16:27] Miguel Solorzano
@Original reporter: Have you tested version 5.2.33?. Thanks in advance.
[23 May 2011 22:35] Sanjiv Gomes
Setting Compatibility mode to XP fixed it for me.
[23 May 2011 22:57] jon lee
I have 5.2.33 installed and am still having this issue.  Why are you asking about the version?  I entered the version when I created the ticket.

I downloaded and installed the "latest" version a few weeks ago.  I'm still unable to start it up successfully in Windows 7 64-bit.  I tried launching it in XP and Vista Compatibility modes with no success.
[26 May 2011 16:18] Alfredo Kojima
There are several different people on this bug and no one seem to have the same symptoms.
As the original reporter has said he cannot repeat the bug any longer, I'll close this as Can't Repeat.
If you still have your problems, please try 5.2.34 (after completely deleting the previous installation of Workbench) and if everything persists even after that, please file a bug or find a bug report that actually matches the effects you see.
[23 Jul 2011 4:04] Craig Krause
This is not exclusive to Win 7 64bit. I just installed MySQL Workbench on Win Vista x86 and immediately after executing run windows informs me that it has stopped working. Exact same problem with version 5.2.34.7780. This is a new install on factory unmodified HP laptop. Has anyone identified a reproducible cause?
[1 Aug 2011 13:24] xiaomei sun
Hi Guys,

Can somebody help me out? 

I got this problem when I ran Workbench:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLWorkbench.exe
  Application Version:	5.2.34.7780
  Application Timestamp:	4ddbbfe9
  Fault Module Name:	atioglxx.dll
  Fault Module Version:	6.14.10.9210
  Fault Module Timestamp:	4b0438cc
  Exception Code:	c0000005
  Exception Offset:	0000b2b2
  OS Version:	6.1.7600.2.0.0.256.48
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Any help will be appreciated.

Thanks,
Sun
[2 Aug 2011 1:32] jon lee
Here are the things I've tried to do in Win7 64-bit Ult.

 - Run as Administrator
 - Tried downloading and running/installing from the MSI, and ZIP formats. Each time the splash screen comes up.  Here's the debug information I was able to glean.

System.AccessViolationException was unhandled
  Message=Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
  Source=wbprivate.wr
  StackTrace:
       at wb.WBContextUI.init(WBContextUI* , WBFrontendCallbacks* , WBOptions* )
       at MySQL.Workbench.WbContext.init(AppImpl application, WbOptions options, VoidStrUIFormDelegate create_main_form_view)
       at MySQL.GUI.Workbench.Program.Main(String[] Args)
  InnerException: 

I'm now looking for a program to check my RAM...
[17 Aug 2011 19:11] Kyle Johnson
Running 5.2.34 CE, Fresh Install.

When opening, the front dashboard shows up, but after double clicking on a server and entering username and password it will error out.

Since I have Visual Studio installed, I went ahead and hit "Debug" and clicked "Continue" on the exception, and it actually opened the connection to the server and am able to run queries.

=================================
Log Name:      Application
Source:        Application Error
Date:          8/17/2011 11:56:14 AM
Event ID:      1000
Description:
Faulting application name: MySQLWorkbench.exe, version: 5.2.34.7780, time stamp: 0x4ddbbfe9
Faulting module name: wbprivate.be.dll, version: 0.0.0.0, time stamp: 0x4ddbbeb7
Exception code: 0xc0000005
Fault offset: 0x000070ce
Faulting process id: 0x1238
Faulting application start time: 0x01cc5d0f46c3a9de
Faulting application path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\MySQLWorkbench.exe
Faulting module path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\wbprivate.be.dll
Report Id: 941fe254-c902-11e0-bb51-6c626de68e21

================================

Log Name:      Application
Source:        .NET Runtime
Date:          8/17/2011 11:56:12 AM
Event ID:      1026
Description:
Application: MySQLWorkbench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
Stack:
   at <Module>.wb.WBContextUI.set_active_form(wb.WBContextUI*, bec.UIForm*)
   at MySQL.Workbench.WbContext.set_active_form(MySQL.Grt.UIForm)
   at MySQL.GUI.Workbench.MainForm.tabControl_SelectedIndexChanged(System.Object, System.EventArgs)
   at System.Windows.Forms.TabControl.OnSelectedIndexChanged(System.EventArgs)
   at MySQL.Controls.FlatTabControl.OnSelectedIndexChanged(System.EventArgs)
   at System.Windows.Forms.TabControl.WmSelChange()
   at System.Windows.Forms.TabControl.set_SelectedIndex(Int32)
   at System.Windows.Forms.TabControl.set_SelectedTab(System.Windows.Forms.TabPage)
   at MySQL.Controls.TabDocument.Activate()
   at MySQL.GUI.Workbench.MainForm.DockDocument(MySQL.Controls.ITabDocument, Boolean, Boolean)
   at MySQL.GUI.Workbench.MainForm.CreateMainFormView(System.String, MySQL.Grt.UIForm)
   at MySQL.Workbench.WbContext.create_main_form_view_wrapper(std.basic_string<char,std::char_traits<char>,std::allocator<char> >*, boost.shared_ptr<bec::UIForm>*)
   at <Module>.sigc.pointer_functor2<std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &,boost::shared_ptr<bec::UIForm>,void>.()()(sigc.pointer_functor2<std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &,boost::shared_ptr<bec::UIForm>,void>*, std.basic_string<char,std::char_traits<char>,std::allocator<char> >*, boost.shared_ptr<bec::UIForm>*)
   at <Module>.sigc.internal.slot_call2<sigc::pointer_functor2<std::basic_string<char,std::char_traits<char>,std::allocator<char> > const &,boost::shared_ptr<bec::UIForm>,void>,void,std::basic_string<char,std::char_traits<char>,std::allocator<char> >,boost::shared_ptr<bec::UIForm> >.call_it(sigc.internal.slot_rep*, std.basic_string<char,std::char_traits<char>,std::allocator<char> >*, boost.shared_ptr<bec::UIForm>*)
   at MySQL.Forms.DrawBoxImpl.drawbox_mouse_double_click(System.Object, System.Windows.Forms.MouseEventArgs)
   at System.Windows.Forms.Control.OnMouseDoubleClick(System.Windows.Forms.MouseEventArgs)
   at System.Windows.Forms.Control.WmMouseUp(System.Windows.Forms.Message ByRef, System.Windows.Forms.MouseButtons, Int32)
   at System.Windows.Forms.Control.WndProc(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.Control+ControlNativeWindow.OnMessage(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.Control+ControlNativeWindow.WndProc(System.Windows.Forms.Message ByRef)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG ByRef)
   at System.Windows.Forms.Application+ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr, Int32, Int32)
   at System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32, System.Windows.Forms.ApplicationContext)
   at System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32, System.Windows.Forms.ApplicationContext)
   at System.Windows.Forms.Application.Run(System.Windows.Forms.ApplicationContext)
   at MySQL.GUI.Workbench.Program.Main(System.String[])
[22 Aug 2011 13:16] Emil Rakoczy
I have just downloaded the 32 bit edition of MySQLWorkbench 5.2.34-2. OS Windows 7 x64 Professional. Crashes on startup. Never installed earlier.

Seems like the program cant run on Windows. Also tried to run as administrator and in compatibility mode.

Any of the developers working on this?! I bet nobody is able to run this software on Windows 7 x64.
[31 Aug 2011 0:32] Alfredo Kojima
The problem appears to be caused by multiple issues, including outdated video drivers and incorrect version of the MSVC 2010 redistributables. You need the 32bit version of the redistributables packages, not the 64bit.
[9 Sep 2011 2:31] Seth Helstrip
Same problem.  Doesn't start on Windows7.  Looks like this bug has been outstanding now for 9 months.  Guess Oracle aren't interested.  If they're not going to fix this, I'm going to need to switch to another database - shame.
[9 Sep 2011 2:31] Seth Helstrip
Same problem.  Doesn't start on Windows7.  Looks like this bug has been outstanding now for 9 months.  Guess Oracle aren't interested.  If they're not going to fix this, I'm going to need to switch to another database - shame.
[10 Sep 2011 8:33] DrZiggy DrZiggy
Thansk Alfredo Kojima. Installing the 32bit version solved the issues I had.
[24 Sep 2011 13:17] Vilmos Katona
The same problem happened to me also, but after i installed the microsoft visual studio 2010, mysql workbench started working again.

The software requirements contains the following for this product:
Microsoft Visual C++ 2010 Redistributable Package (x86)

I would suggest installing it again.
Vil
[24 Sep 2011 20:51] Paulo Martins
Workbench 5.2.35 continues to refuse to start.
The problem occurs on Windows 7 Home Premium and Professional, both x64.
No error message is displayed.
However, analysing the Event Log there are two entries for every time I try to start Workbench.
The first is a .Net Runtime error:
Application: MySQLWorkbench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException
Stack:
   at MySQL.GUI.Workbench.Program.Main(System.String[])

The Second is an Application Error:
Faulting application name: MySQLWorkbench.exe, version: 5.2.35.7915, time stamp: 0x4e7957cf
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319
Exception code: 0xe0434352
Fault offset: 0x0000b9bc
Faulting process id: 0xab8
Faulting application start time: 0x01cc7af92742a16b
Faulting application path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\MySQLWorkbench.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 663c6cf2-e6ec-11e0-b460-74f06dc49bc2

I think it is up to Oracle to solve this one.

Best regards.

Paulo Martins
[24 Sep 2011 20:51] Paulo Martins
Workbench 5.2.35 continues to refuse to start.
The problem occurs on Windows 7 Home Premium and Professional, both x64.
No error message is displayed.
However, analysing the Event Log there are two entries for every time I try to start Workbench.
The first is a .Net Runtime error:
Application: MySQLWorkbench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException
Stack:
   at MySQL.GUI.Workbench.Program.Main(System.String[])

The Second is an Application Error:
Faulting application name: MySQLWorkbench.exe, version: 5.2.35.7915, time stamp: 0x4e7957cf
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319
Exception code: 0xe0434352
Fault offset: 0x0000b9bc
Faulting process id: 0xab8
Faulting application start time: 0x01cc7af92742a16b
Faulting application path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\MySQLWorkbench.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 663c6cf2-e6ec-11e0-b460-74f06dc49bc2

I think it is up to Oracle to solve this one.

Best regards.

Paulo Martins
[24 Sep 2011 20:51] Paulo Martins
Workbench 5.2.35 continues to refuse to start.
The problem occurs on Windows 7 Home Premium and Professional, both x64.
No error message is displayed.
However, analysing the Event Log there are two entries for every time I try to start Workbench.
The first is a .Net Runtime error:
Application: MySQLWorkbench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException
Stack:
   at MySQL.GUI.Workbench.Program.Main(System.String[])

The Second is an Application Error:
Faulting application name: MySQLWorkbench.exe, version: 5.2.35.7915, time stamp: 0x4e7957cf
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319
Exception code: 0xe0434352
Fault offset: 0x0000b9bc
Faulting process id: 0xab8
Faulting application start time: 0x01cc7af92742a16b
Faulting application path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\MySQLWorkbench.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 663c6cf2-e6ec-11e0-b460-74f06dc49bc2

I think it is up to Oracle to solve this one.

Best regards.

Paulo Martins
[24 Sep 2011 20:51] Paulo Martins
Workbench 5.2.35 continues to refuse to start.
The problem occurs on Windows 7 Home Premium and Professional, both x64.
No error message is displayed.
However, analysing the Event Log there are two entries for every time I try to start Workbench.
The first is a .Net Runtime error:
Application: MySQLWorkbench.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException
Stack:
   at MySQL.GUI.Workbench.Program.Main(System.String[])

The Second is an Application Error:
Faulting application name: MySQLWorkbench.exe, version: 5.2.35.7915, time stamp: 0x4e7957cf
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319
Exception code: 0xe0434352
Fault offset: 0x0000b9bc
Faulting process id: 0xab8
Faulting application start time: 0x01cc7af92742a16b
Faulting application path: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE\MySQLWorkbench.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 663c6cf2-e6ec-11e0-b460-74f06dc49bc2

I think it is up to Oracle to solve this one.

Best regards.

Paulo Martins
[25 Sep 2011 14:33] Paulo Martins
Problem solved.

It is imperative that the Microsoft Visual C++ 2010 SP1 Redistributable Package (x86) is installed, regardless of whether the OS is x86 or x64.
As there is an SP1 available this should be the preferred one.
Here goes the link: http://www.microsoft.com/download/en/details.aspx?id=8328.

Best regards.
[2 Nov 2011 8:50] ksdhnv khdkjfv
Dear sir,

I am using Windows 7 64bit machine. I am unable to use MySQL Workbench. When i open it it is showing the error [ CLR error:80004005 ]. I read a post in the blog that we need to remove the folder in the C:\Users\Neo\AppData\Roaming\MySQL\Workbench i have done it but still i am getting same error. Please some one help me up.

I installed 5.2 CE version workbench.

prithvikrishnab4u@gmail.com
[12 Dec 2011 10:13] Tom Litchfield
Thank you Paulo Martins, your solution solved the problem on my machine. Thanks for sharing!
[26 Mar 2012 9:26] Luke Van In
The problem still exists in version 5.2 CE, even with vcredist installed.

----------------------------

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	MySQLWorkbench.exe
  Application Version:	5.2.38.8753
  Application Timestamp:	4f43fc17
  Fault Module Name:	wbprivate.be.dll
  Fault Module Version:	0.0.0.0
  Fault Module Timestamp:	4f43f519
  Exception Code:	c0000005
  Exception Offset:	0023a512
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	7177
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
[7 Aug 2012 1:14] Pawel No
I had same issue on Win 7 Pro, the program would crush on start up all the time.  I followed different solutions by different people on the internet.  Finally what worked is, i uninstalled .NET 4 client, all c++  redistributables and deleted all old MySQL directories in user profiles.  Then did a fresh install of .NET 4 Client.  Updated it to the latest through the windows update, then installed C++ 2010 Redistributable but did it with the wrong version (64bit).  Thanks to Alfredo on this thread reinstalled the 32bit.  Now i am a happy Workbench user.
[19 Oct 2013 0:26] Angel Pineda
Hola a Todos

Después de leer sin encontrar una buena solución a este problema, llegue a este foro y gracias a las respuesta de Johannes Taxacher , Paulo Martins y Pawel No pude revivir MySQL Workbench Version 6.0 Build 6.0.6.11184

MySQL WB esta instalado sobre Window 7 Home Premium x64 (Dell inspiron 5520)

Debo aclarar que era la primera vez que instalaba MySQL en mi equipo.

Por lo tanto la respuesta de: Paulo Martins

Ref:
>>[25 Sep 2011 14:33] Paulo Martins
>>Here goes the link: http://www.microsoft.com/download/en/details.aspx?id=8328.

la realice primero.

Después borre el directorio que indicó: Johannes Taxacher

Ref
>>[11 Jan 2010 11:20] Johannes Taxacher
>>C:\Users\<yourusername>\AppData\Roaming\MySQL\Workbench

por último, lo confirmo todo: Pawel No

En su texto

Ref
>>[7 Aug 2012 1:14] Pawel No

Gracias
Miguel F.