Bug #50179 rpl_backup_shutdown crashes server on PB2
Submitted: 8 Jan 2010 10:43 Modified: 11 Jan 2010 16:47
Reporter: Andrei Elkin Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Backup Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: Assigned Account CPU Architecture:Any

[8 Jan 2010 10:43] Andrei Elkin
Description:
Symptoms are like
https://central.sun.net/http://pb2.norway.sun.com/?template=mysql_show_test_failure&test_f...
rpl.rpl_backup_shutdown                  [ fail ]
        Test ended at 2010-01-08 01:56:30

CURRENT_TEST: rpl.rpl_backup_shutdown

Server [mysqld.2 - pid: 24975, winpid: 24975, exit: 256] failed during test run
Server log from this test:
100108  3:56:24 [Note] Plugin 'FEDERATED' is disabled.
100108  3:56:24 [Note] Plugin 'InnoDB' is disabled.
100108  3:56:24 [Note] Plugin 'ndbcluster' is disabled.
100108  3:56:24 [Warning] /export/home4/pb2/test/sb_3-1160930-1262898790.58/mysql-5.6.0-beta-linux-x86_64-test/libexec/mysqld: unknown variable 'loose-debug-sync-timeout=300'
100108  3:56:24 [Note] Event Scheduler: Loaded 0 events
100108  3:56:24 [Note] /export/home4/pb2/test/sb_3-1160930-1262898790.58/mysql-5.6.0-beta-linux-x86_64-test/libexec/mysqld: ready for connections.
Version: '5.6.0-beta-log'  socket: '/export/home4/pb2/test/sb_3-1160930-1262898790.58/tmp/745j3gG5es/mysqld.2.sock'  port: 13001  Source distribution
100108  3:56:25 [Note] Slave I/O thread: connected to master 'root@127.0.0.1:13000',replication started in log 'FIRST' at position 4
100108  3:56:25 [Note] Slave SQL thread initialized, starting replication in log 'FIRST' at position 0, relay log './slave-relay-bin.000001' position: 4
100108  3:56:26 [Note] Slave: received end packet from server, apparent master shutdown: 
100108  3:56:26 [Note] Slave I/O thread: Failed reading log event, reconnecting to retry, log 'master-bin.000001' at postion 2920
100108  3:56:26 [ERROR] Slave I/O: error reconnecting to master 'root@127.0.0.1:13000' - retry-time: 1  retries: 60, Error_code: 2003
100108  3:56:29 [Note] Slave I/O thread killed during or after a reconnect done to recover from failed read
100108  3:56:29 [Note] Slave I/O thread exiting, read up to log 'master-bin.000001', position 2920
100108  3:56:30 [Note] Slave I/O thread: connected to master 'root@127.0.0.1:13000',replication started in log 'master-bin.000001' at position 2920
100108  3:56:30 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=1048576
read_buffer_size=131072
max_used_connections=2
max_threads=151
thread_count=2
connection_count=2
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 60652 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x16f3e300
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0x410850e8 thread_stack 0x40000

The test also has a failure w/o the crash:

rpl.rpl_backup_shutdown                  [ fail ]
        Test ended at 2010-01-08 07:27:51

CURRENT_TEST: rpl.rpl_backup_shutdown
--- /export/home2/pb2/test/sb_1-1161308-1262922187.43/mysql-5.6.0-beta-solaris10-x86_64-test/mysql-test/suite/rpl/r/rpl_backup_shutdown.result	2010-01-08 02:55:44.000000000 +0300
+++ /export/home2/pb2/test/sb_1-1161308-1262922187.43/mysql-5.6.0-beta-solaris10-x86_64-test/mysql-test/suite/rpl/r/rpl_backup_shutdown.reject	2010-01-08 09:27:51.155348000 +0300
@@ -139,7 +139,7 @@
 Replicate_Wild_Do_Table	
 Replicate_Wild_Ignore_Table	
 Last_Errno	1590
-Last_Error	The incident RESTORE_ON_MASTER occured on the master. Message: A restore operation was initiated on the master.
+Last_Error	The incident ¾ occured on the master. Message: A restore operation was initiated on the master.
 Skip_Counter	0
 Exec_Master_Log_Pos	#
 Relay_Log_Space	#
@@ -157,7 +157,7 @@
 Last_IO_Errno	0
 Last_IO_Error	
 Last_SQL_Errno	1590
-Last_SQL_Error	The incident RESTORE_ON_MASTER occured on the master. Message: A restore operation was initiated on the master.
+Last_SQL_Error	The incident ¾ occured on the master. Message: A restore operation was initiated on the master.

on https://central.sun.net/http://pb2.norway.sun.com/?template=mysql_show_test_failure&test_f...

How to repeat:
To see PB2 or to run the test.
[10 Jan 2010 1:58] Libing Song
It seems certain that this bug is a duplicate of bug#50175
[11 Jan 2010 16:47] Andrei Elkin
LiBing, that's correct. I was waiting for PB2 to confirm that.