Bug #50126 cannot install monitor agent on snow leopard
Submitted: 7 Jan 2010 6:06 Modified: 14 Jan 2010 14:48
Reporter: Mikiya Okuno Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Monitor: Installing Severity:S2 (Serious)
Version:2.1.0.1093 OS:Mac OS X (10.6.2)
Assigned to: Andy Bang CPU Architecture:Any

[7 Jan 2010 6:06] Mikiya Okuno
Description:
Similar to bug #47042, I cannot install agent on Mac OS X Snow Leopard. The installer binary which I use is mysqlmonitoragent-2.1.0.1093-osx-installer.app. The installer proceeds til the end, but it reports the error in the middle way. I will attach the error message later.

How to repeat:
Install MEM agent on Mac OS X Snow Leopard.

Suggested fix:
As Kent said, we no longer bundle libxml in the agent package on Mac OS X, that caused the problem described in this bug report. We instead uses the system libxml. So fix should be made around there.
[7 Jan 2010 6:06] Mikiya Okuno
Error message

Attachment: Screen shot 2010-01-07 at 3.03.48 PM.png (image/png, text), 60.30 KiB.

[8 Jan 2010 1:27] Gary Whizin
Confirmed fixed in 2.1.1.1137
[14 Jan 2010 14:48] MC Brown
A note has been added to the 2.1.1 changelog: 

The agent could not be installed on Mac OS X Snow Leopard (10.6) due to an incompatibility in the XML libraries used.