Bug #50059 IBMDB2I storage engine not included in 64-bit MySQL 5.1.42
Submitted: 4 Jan 2010 17:33 Modified: 22 Jan 2010 12:46
Reporter: Tim Clark Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S1 (Critical)
Version:5.1.42 OS:IBM i
Assigned to: Timothy Smith
Tags: 64bit, ibmdb2i, regression
Triage: Triaged: D1 (Critical)

[4 Jan 2010 17:33] Tim Clark
Description:
The 64-bit tar package of MySQL 5.1.42 does not include the IBMDB2I storage engine.

Here's what I see when I look in the plugin directory:

> ls /tmp/mysql-5.1.42-i5os-power-64bit/lib/plugin
  ha_innodb_plugin.a          ha_innodb_plugin.so.0.0.0   libdaemon_example.so.0      mypluglib.so
  ha_innodb_plugin.la         libdaemon_example.a         libdaemon_example.so.0.0.0  mypluglib.so.0
  ha_innodb_plugin.so         libdaemon_example.la        mypluglib.a                 mypluglib.so.0.0.0
  ha_innodb_plugin.so.0       libdaemon_example.so        mypluglib.la
  $                                                                                                  

How to repeat:
See description

Suggested fix:
Include the storage engine in the 64-bit build.
[12 Jan 2010 6:53] Sveta Smirnova
Thank you for the report.

Verified as described. 32-bit package is not affected.
[23 Jan 2010 0:22] Paul Dubois
Noted in 5.1.43 changelog.

The IBMDB2I storage engine was missing from the i5os 64-bit
distribution of MySQL 5.1.42. It is now included again.
[27 Jan 2010 15:54] Valerii Kravchuk
Bug #50634 was marked as a duplicate of this one.