Bug #50045 Binlog related tests fail when using gcc 4.4
Submitted: 4 Jan 2010 10:16 Modified: 13 Jan 2010 15:25
Reporter: Norbert Tretkowski Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests: Replication Severity:S3 (Non-critical)
Version:5.1.42, 5.1.43 bzr OS:Linux
Assigned to: CPU Architecture:Any

[4 Jan 2010 10:16] Norbert Tretkowski
Description:
When building MySQL 5.1.42 with gcc 4.4.2, the testsuite fails in all binlog related tests.

How to repeat:
Build MySQL 5.1.42 with gcc 4.4.2 and run the testsuite.
[4 Jan 2010 10:17] Norbert Tretkowski
Error when running testsuite

Attachment: testsuite.log (text/x-log), 1.25 KiB.

[4 Jan 2010 10:18] Norbert Tretkowski
All query results

Attachment: binlog_innodb.log (text/x-log), 1.95 KiB.

[11 Jan 2010 14:26] Norbert Tretkowski
The initial problem happened on Debian unstable using gcc 4.4.2, but I was just able to reproduce the problem on Fedora 12 using gcc 4.4.2 20091222.
[12 Jan 2010 9:34] Sveta Smirnova
Thank you for the report.

Verified using gcc 4.4.0 om RedHat 5. In my case failed following tests:

Failing test(s): binlog.binlog_multi_engine binlog.binlog_stm_do_db binlog.binlog_row_mix_innodb_myisam binlog.binlog_stm_mix_innodb_myisam binlog.binlog_innodb
[12 Jan 2010 16:32] Luis Manuel Oliveira Soares
See: BUG#48357
[13 Jan 2010 14:50] Sveta Smirnova
Norbert,

I can not repeat described behavior second time for some reason. Could you please try with current bzr 5.1 sources: probably this is duplicate of bug #48357 and patch pushed already. Thanks in advance.
[13 Jan 2010 15:04] Norbert Tretkowski
Sveta,

the patch from #48357 indeed fixes the issue, sorry for reporting this duplicate bugreport.

Norbert
[13 Jan 2010 15:25] Sveta Smirnova
Norbert,

thank you for the update. Closing report as duplicate.