Bug #49974 Assertion `main_da.is_error()' from handle_delayed_insert()
Submitted: 29 Dec 2009 11:41 Modified: 8 Jan 2010 13:34
Reporter: Philip Stoev Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:mysql-next-mr-wl3561 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Triage: Triaged: D1 (Critical)

[29 Dec 2009 11:41] Philip Stoev
Description:
When executing a concurrent DDL workload + transactional LOCK TABLE, mysqld asserted as follows:

mysqld: sql_class.h:1997: void THD::fatal_error(): Assertion `main_da.is_error()' failed.

thd->query at 0x1bbaa38 = t1_base1_N
thd->thread_id=507
thd->killed=KILL_CONNECTION

#0  0x000000315b00c216 in pthread_kill () from /lib64/libpthread.so.0
#1  0x00000000009b863d in my_write_core (sig=6) at stacktrace.c:307
#2  0x000000000062f87a in handle_segfault (sig=6) at mysqld.cc:2614
#3  <signal handler called>
#4  0x000000315a432ed5 in raise () from /lib64/libc.so.6
#5  0x000000315a434a43 in abort () from /lib64/libc.so.6
#6  0x000000315a42bec9 in __assert_fail () from /lib64/libc.so.6
#7  0x000000000064cfdc in THD::fatal_error (this=0x1caac58) at sql_class.h:1997
#8  0x00000000006dcc6b in handle_delayed_insert (arg=0x1caac38) at sql_insert.cc:2394
#9  0x000000315b0073da in start_thread () from /lib64/libpthread.so.0
#10 0x000000315a4e627d in clone () from /lib64/libc.so.6

See also bug 45067 which is about a similar assertion in a similar situation.

How to repeat:
If this is repeatable, a test case will be provided. In the meantime, the core and the binary will be made available.
[29 Dec 2009 11:43] Philip Stoev
Core and binary:

http://mysql-systemqa.s3.amazonaws.com/var-bug49974.zip

Source:

revision-id: ingo.struewing@sun.com-20091221154123-51irmivi5ey9mt57
date: 2009-12-21 16:41:23 +0100
build-date: 2009-12-28 17:01:04 +0200
revno: 2943
branch-nick: mysql-next-mr-wl3561
[29 Dec 2009 11:54] Philip Stoev
I am setting this to Verified with the expectation that diagnostics_area bugs can be debugged based on core file alone, or that this bug will be closed as a duplicate to the previously reported DA bug involving killing delayed insert.
[7 Jan 2010 10:29] Jon Olav Hauglid
The fix for Bug#45067 is currently not present in mysql-next-mr-wl3561.
[8 Jan 2010 13:34] Jon Olav Hauglid
Closing the bug as a duplicate of Bug#45067.
(The fix for Bug#45067 was not present in mysql-next-mr-wl3561 when this bug was reported)