Bug #49721 .mwb filter in explorer dialogue for opening models does not filter
Submitted: 15 Dec 2009 19:27 Modified: 16 Dec 2009 14:55
Reporter: Peter Laursen (Basic Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.10 OS:Microsoft Windows (7 -64 bit)
Assigned to: CPU Architecture:Any

[15 Dec 2009 19:27] Peter Laursen
Description:
When opening a .mwb from "Data Modeling..Open Existing .ERR file" (WB startup screen) a Windows Explorer dialog opens with .mwb preconfigured if the filter setting.  However the filter has no effect. All sorts of files are displayed. Additionally the string ".mwb" is truncated.

How to repeat:
image coming ..

Suggested fix:
I think I have never seen a Windows Explorer dialog looking exactly like this before .. looks like some cross-platform library/wrapper has a problem here.
[15 Dec 2009 19:29] Peter Laursen
Files with .url extension in the folder (my Windows desktop) listed regardless of .mwb filter

Attachment: filter.jpg (image/jpeg, text), 75.25 KiB.

[15 Dec 2009 19:32] Peter Laursen
corrected synopsis
[16 Dec 2009 14:06] Susanne Ebrecht
Peter,

we are not able to repeat this.

Do you maybe have another hint for us?
[16 Dec 2009 14:55] Peter Laursen
I am sorry.  Files with .txt and .jpg extension are not listed.  Those links to webpages (displayed with Opera icon on my system) also appear in Windows Explorer with native Windows programs.  So not a bug.