Bug #49704 Can't uninstall workbench (on ubuntu linux) after it got corrupted
Submitted: 15 Dec 2009 8:19 Modified: 17 Dec 2009 10:32
Reporter: Nidhi Shrotriya Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.10 OS:Linux (ubuntu 9.04)
Assigned to: CPU Architecture:Any

[15 Dec 2009 8:19] Nidhi Shrotriya
Today while working with WB I did something (don't remember  :-(  ) that seemed to have corrupted my installation.
Every time I click on Server Administration a window opens that asks me to 'wait' or 'force quit' and finally I have to force quit.

Now I have 2 issues -

1) I tried to uninstall my installation and install again.

Followed below steps (as mentioned in the documentation)

nidhi@nidhi-laptop:~/Desktop$ sudo dpkg -r mysql-workbench-oss
(Reading database ... 128704 files and directories currently installed.)
Removing mysql-workbench-oss ...

nidhi@nidhi-laptop:~/Desktop$ mysql-workbench
bash: /usr/bin/mysql-workbench: No such file or directory

nidhi@nidhi-laptop:~/Desktop$ sudo dpkg --purge mysql-workbench-oss
dpkg - warning: ignoring request to remove mysql-workbench-oss which isn't installed.

nidhi@nidhi-laptop:~/Desktop$ sudo dpkg -i mysql-workbench-oss-5.2.10-1ubu904-i386.deb
Selecting previously deselected package mysql-workbench-oss.
(Reading database ... 128021 files and directories currently installed.)
Unpacking mysql-workbench-oss (from mysql-workbench-oss-5.2.10-1ubu904-i386.deb) ...
Setting up mysql-workbench-oss (5.2.10-1ubu904) ... 

But it didn't seem to have solved my problem and on invoking mysql-workbench I see everything I configured and the problem persists.

I am attaching .tar.gz for reference.

2) I deleted everything from within ~/.mysql/workbench and finally could launch a fresh instance of mysql-workbench. But now if I try to uninstall

nidhi@nidhi-laptop:~$ sudo dpkg -r mysql-workbench-oss
dpkg: status database area is locked by another process

How to repeat:
As mentioned in the description.
[15 Dec 2009 8:20] Nidhi Shrotriya
Workbench config dir.

Attachment: mysql-wb.tar.gz (application/x-gzip, text), 4.18 KiB.

[15 Dec 2009 8:54] Johannes Taxacher
we'll look into the config files to see if we can find the part that must have caused the corruption.
as for the locked dpkg, that doesn't sound like its caused by WB. sounds more like maybe an automatic update is running/pending in background or sth. like that.
[17 Dec 2009 10:32] Susanne Ebrecht
Many thanks for writing a bug report.

Unfortunately, the described problem is not a bug.

The described problem is related to typical Debian/Ubuntu package installation.