Bug #4951 myisamchk crash
Submitted: 9 Aug 2004 13:41 Modified: 13 Aug 2004 20:12
Reporter: Andreas Götz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S1 (Critical)
Version:4.1.3-beta OS:Microsoft Windows (WinXP SP1)
Assigned to: Assigned Account CPU Architecture:Any

[9 Aug 2004 13:41] Andreas Götz
Description:
After upgrading mysql from 4.0.20 to 4.1.3-beta, I've experienced table problems with 1 bigger table being replicated to my slave. After shutdown I ran 
myisamchk *.myi

and experience a repeatable crash:

instruction 0x77f69ecd referenced memory at 0x00000010

How to repeat:
run myisamchck (any table!)
[9 Aug 2004 13:43] Andreas Götz
Forgot one important detail: crash only happens when running with -e switch. Without switches, this is the output:

[FSCZ0KW691WKYSX] D:\mysql\data>"C:\Program Files\mysql\bin\myisamchk.exe"  supportweb\*.myi
Checking MyISAM file: supportweb\sr.MYI
Data records:    1189   Deleted blocks:       0
- check file-size
- check record delete-chain
- check key delete-chain
- check index reference
- check data record references index: 1
- check data record references index: 2
- check data record references index: 3
- check data record references index: 4
- check data record references index: 5
- check data record references index: 6
- check data record references index: 7
- check data record references index: 8
- check data record references index: 9
- check record links

---------

Checking MyISAM file: supportweb\srcontent.MYI
Data records:    2029   Deleted blocks:       2
- check file-size
- check record delete-chain
- check key delete-chain
- check index reference
- check data record references index: 1
- check data record references index: 2
- check data record references index: 3
- check record links

---------

Checking MyISAM file: supportweb\srstatus.MYI
Data records:    7846   Deleted blocks:       0
- check file-size
- check record delete-chain
- check key delete-chain
- check index reference
- check data record references index: 1
- check data record references index: 2
- check record links
[13 Aug 2004 20:12] Dean Ellis
This is a duplicate of bug #4901; fixed in 4.1.4.