Bug #49449 crash when closing workbench
Submitted: 4 Dec 2009 9:11 Modified: 25 May 2010 7:51
Reporter: mister kredo Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.18 OS:Any (Vista SP2)
Assigned to: CPU Architecture:Any

[4 Dec 2009 9:11] mister kredo
Description:
0015fa64 09526302 000007d0 00000809 0015fa7c libmysql!mysql_fetch_field+0x51d25
0015fa74 09529695 70b5cca9 04255203 813b00a5 libmysql!mysql_fetch_field+0x31a5e
0015fa7c 04255203 813b00a5 07d9c76c 07e5f528 libmysql!mysql_fetch_field+0x34df1
0015fab8 04257028 07e78ba8 04257013 00000001 mysqlcppconn!sql::NonScrollableException::copy+0x2d83
00000000 00000000 00000000 00000000 00000000 mysqlcppconn!sql::NonScrollableException::copy+0x4ba8

How to repeat:
Just close Workbench.
[4 Dec 2009 9:19] mister kredo
I uploaded 3 dumps of workbench on ftp. according to issue.
[5 Dec 2009 1:56] Miguel Solorzano
Thank you for the bug report. I couldn't repeat this issue on Vista Premium 64-bit, is there some special step before to exit the application?. Thanks in advance.
[5 Dec 2009 14:33] mister kredo
The problem reproduced also on Xp sp3 32-bit platform. Excuse me, I forget to specify that bug was found on Vista SP2 32-bit platform. 
It was reproduced when having an opened project, then closing Workbench withoout closing opened projects.
Try to reproduce in that way:
1. create a new reverse engineering project
2. save it (mwb) on disc but do not close project
3. close workbench. crash should appear.
[8 Dec 2009 13:55] Susanne Ebrecht
This should be fixed in Workbench 5.2.10.

Do you still have this crashes by using Workbench 5.2?
[8 Dec 2009 16:54] mister kredo
I can't test this option because the feature is not available in 5.2 version of Workbench.
[8 Dec 2009 16:56] mister kredo
This feature is grayed out as I don't have the version (paid?) to can use it.
[10 Dec 2009 13:49] Susanne Ebrecht
I could repeat this with Workbench 5.2 SE on Ubuntu.

1) Reverse engineer database MySQL
2) Play a little bit with routines
3) save as foo.mwb
4) File -> Exit

Here is the error message:

Invalid request ("SHUTDOWN", ())

Error in my_thread_global_end(): 1 threads didn't exit
[12 Apr 2010 13:00] Alfredo Kojima
Hi

Can you try repeating that with the latest 5.2 release?
Thank you.
[12 Apr 2010 13:07] mister kredo
This feature is grayed out as I don't have the version (paid?) to can
use it.
SO,
I can't test this option because the feature is not available in 5.2
version of Workbench.
[16 Apr 2010 13:19] Valeriy Kravchuk
What exact "grayed out" feature are you talking about? All actions you mentioned in the initial description should work on 5.2.18 beta (OSS). Please, check.
[16 Apr 2010 13:49] mister kredo
Can't do Reverse Engineer as it is grayed out

Attachment: mysqlworkbug.jpg (image/jpeg, text), 72.12 KiB.

[16 Apr 2010 13:51] mister kredo
I've attached the image with feature that si grayed out and I can't test. Also, failure on opening workbench models created with 5.1.18a version.
[16 Apr 2010 13:55] mister kredo
Can't open model created with 5.1.18a version in 5.2.18 version.

Attachment: mysqlworkbug2.jpg (image/jpeg, text), 16.85 KiB.

[23 Apr 2010 15:35] Valeriy Kravchuk
Please, check if the problem is repeatable with a newer version, 5.2.19. Reverse engineer menu item is availabe there - you have just to create new, empty ERR model. Also if you have a problem with opening any .mwb file from older version, please, upload this file.
[23 May 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[24 May 2010 9:44] mister kredo
could not reproduce with 5.2.21 rc.
[25 May 2010 7:51] Valeriy Kravchuk
Not repeatable with 5.2.21.