Bug #49439 Unhandled exception when accessing variables, logs, etc. on stopped server
Submitted: 3 Dec 2009 23:50 Modified: 9 Feb 2010 10:24
Reporter: Todd Farmer (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.10 r4680 OS:Microsoft Windows (XP)
Assigned to: Alfredo Kojima CPU Architecture:Any

[3 Dec 2009 23:50] Todd Farmer
Description:
When the server is offline, and I try to access the logs, accounts, connections, variables or data dump functions, I get unhandled exception messages.

It looks like the problem is actually being handled, and perhaps just the message is wrong.  It might also be useful to disable these tabs when the server is unavailable.

How to repeat:
See above.

Suggested fix:
See above.
[3 Dec 2009 23:51] Todd Farmer
Screenshot

Attachment: SP32-20091203-154831.gif (image/gif, text), 7.99 KiB.

[2 Feb 2010 4:01] Alfredo Kojima
Forced disconnection when server is stopped, which will disable the parts that depend on a db connection.
[3 Feb 2010 17:13] Johannes Taxacher
fix confirmed in repository
[9 Feb 2010 10:24] Tony Bedford
An entry has been added to the 5.2.16 changelog:

If the MySQL Server was stopped then attempting to access the Logs, Accounts, Connections, Variables or Data Dump tabs in the Administrator resulted in unhandled exceptions.