Bug #49383 Remove useless options from table definition context menu
Submitted: 2 Dec 2009 23:43 Modified: 6 Jan 2010 15:46
Reporter: Todd Farmer (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.10 r4680 OS:Microsoft Windows (XP)
Assigned to: Mike Lischke CPU Architecture:Any

[2 Dec 2009 23:43] Todd Farmer
Description:
In the SQL Editor, I select a table from the schemata tab on the right hand side.  This displays the table definition in a disabled text area below the schemata object tree.  When I right-click on this, I am presented with a number of options, many disabled, and some that probably should be.  Those which are active and are useless, AFAICT:

* Paste
* Show Unicode control characters
* Insert Unicode control character -> ...

I'm not entirely sure about the "Right to left Reading order" (actual capitalization), either, but it at least does something.

How to repeat:
See above.

Suggested fix:
Remove useless/inappropriate options from menu.
[3 Dec 2009 21:47] Alfredo Kojima
Sound like standard/system control menu items.
[6 Jan 2010 15:46] Mike Lischke
Indeed, this is a standard context menu for Windows' own edit controls and have their special meaning (usually not for the average user but that is how MS designed it). Since this is a menu controlled by Windows itself we only could replace it entirely, which isn't worth the effort. Is does exactly what it is supposed to do, even if that is not of much use for everybody.