Bug #49321 Got an error reading communication packets
Submitted: 2 Dec 2009 1:34 Modified: 13 Dec 2009 8:19
Reporter: Michael Heuberger Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.1 (Comminity Server) OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: Communicatipn Packets, network, php

[2 Dec 2009 1:34] Michael Heuberger
Description:
Good day

After searching the web and your forum for many hours I haven't found a solution to the following problem:

By random I am getting Internal Server Errors. Sometimes now. When checking the log files on MySQL Server I am seeing lines like this:

"091202 14:18:14 [Warning] Aborted connection 29 to db: 'bk_website' user: 'robot' host: 'localhost' (Got an error reading communication packets)"

I am developping my own website on localhost on Zend Server. The PHP code connects to the MySQL Server which is also on localhost.

I found out that the faster I click on the test website, meaning the more DB connections are made, the higher the chance is that the connection will be aborted.

I tried to tweak some ini settings but none of these seems to work.

How to repeat:
I am happy to send you the source code and my ini files so that you can reproduce.

Suggested fix:
I have no fix. I hope you can point me where the problem lies.
[2 Dec 2009 1:35] Michael Heuberger
Changed version and OS.
[2 Dec 2009 1:35] Michael Heuberger
The current ini file with all the settings ...

Attachment: my.ini (application/octet-stream, text), 8.86 KiB.

[2 Dec 2009 2:08] Miguel Solorzano
I was experiencing the same issue on Windows Vista 64-bit and the cause (at least how I fixed the issue) was a problem with network connection settings with a missed default gateway.
[2 Dec 2009 2:10] Michael Heuberger
Thank you Miguel.

Can you tell me how exactly you fixed that issue under Windows?
[2 Dec 2009 11:02] Miguel Solorzano
I edited the connection properties (IPV4) the field default gateway 192.168.0.XX which is the IP of the router in my local lan. Anyway it was network issue.
[2 Dec 2009 11:09] Michael Heuberger
Mmmhhh... this makes no sense because I am running everything on localhost. Your trick won't work for me.

By the way, I found out that the PHP-CGI.exe was also crashing when that error happened. So I assume it's rater a PHP problem than a MySQL one. Because that Zend's PHP-CGI.exe hasn't been tested for Windows 7 yet...
[2 Dec 2009 11:36] Miguel Solorzano
Yes I wasn't sure about the cause I just commented you about my case when I fixed the connection properties the issue stopped.
[13 Dec 2009 8:19] Sveta Smirnova
Thank you for the update.

Closing as "Not a Bug" as cause is not MySQL.