Bug #49278 Multiple auto-increment columns allowed incorrectly
Submitted: 1 Dec 2009 17:13 Modified: 11 May 2010 10:49
Reporter: Todd Farmer (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:5.2 r4643 OS:Microsoft Windows (XP)
Assigned to: Alfredo Kojima CPU Architecture:Any

[1 Dec 2009 17:13] Todd Farmer
Description:
WB allows users to define two different numeric columns as auto-increment, incorrectly.  The resulting DDL cannot be applied.

How to repeat:
Create a table with two INT columns, check AI for both.

Suggested fix:
Only allow one AI per table.
[2 Dec 2009 9:25] Susanne Ebrecht
I think this is not a bug at the moment.

Validation check only is included in Workbench SE.

Checking AI on two columns should work in SE.

My guess here is that you tested OSS and not SE.

Is my guess right?
[14 Jan 2010 7:32] Susanne Ebrecht
Many thanks for writing a bug report.

There is no validation check here in life editor for more then single auto_inc.
[3 May 2010 13:35] Alfredo Kojima
Changed so that previously set auto-inc columns are unset if a new one is toggled.
[10 May 2010 22:23] Johannes Taxacher
fix confirmed in repository
[11 May 2010 10:49] Tony Bedford
An entry has been added to the 5.2.21 changelog:

MySQL Workbench allowed setting the auto-increment checkbox for multiple columns in the Table Editor.