Bug #49229 Cannot connect to SSL-secured MySQL server
Submitted: 30 Nov 2009 19:17 Modified: 20 Oct 2010 13:47
Reporter: Chris Gross Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2 beta OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Tags: workbench ssl
Triage: Needs Triage: D5 (Feature request) / R4 (High) / E4 (High)

[30 Nov 2009 19:17] Chris Gross
Description:
This is a re-report of a bug (#41234) that occurs in all previous mysql GUI applications.

The last dev post on the previous report suggested using the Workbench product. However, like the GUI tools before it, workbench cannot connect to a mysql server that requires SSL. The methods attempted to connect are:

1) TCP/IP over SSH in workbench
2) SSH Tunnel using external SSH application and TCP/IP in workbench

Non-SSL connections can be established using both methods to a non-ssl required port of the same MySQL server.

Refer to bug #41234 for the detailed information.

How to repeat:
1) Have a SSL-required MySQL server that is only accessible from another remote server.

2) Use TCP/IP over SSH in workbench to create a connection.  Place the remote server's information in the SSH fields and the MySQL server information in the MySQL fields.

3) Check 'Use SSL if available' on the advanced tab of the connection's properties.
[20 Oct 2010 13:47] Alfredo Kojima
Marking as duplicate of bug #57101 which has been implemented recently