Bug #49220 --single-transaction option missing from WB backups?
Submitted: 30 Nov 2009 17:43 Modified: 5 Feb 2010 15:59
Reporter: Todd Farmer (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2 r4643 OS:Microsoft Windows (XP)
Assigned to: Alfredo Kojima CPU Architecture:Any

[30 Nov 2009 17:43] Todd Farmer
Description:
It appears that not all of the mysqldump options supported by MySQL Administrator were implemented in WB.  Of greatest concern is the apparent lack of support for --single-transaction, which is crucial for generation of consistent backups across multiple InnoDB tables.  Having consistent data in a backup is a critical requirement of any backup solution, so if this is implemented differently in WB (say, no option to turn it off), please let me know.

Also, has a feature comparison been done between WB and MA (and QB) to ensure there is no loss of functionality such as missing options?

How to repeat:
Look for an option for --single-transaction during export.

Suggested fix:
Add option.
[30 Nov 2009 17:45] Todd Farmer
Also apparently missing --master-data options.
[30 Jan 2010 1:40] Alfredo Kojima
The dump code has been modified to allow single transaction to be specified.

 If that option is enabled, the table selection will be restricted the following way:
- if a single schema is selected, you may select/deselect its tables as you wish
- if more than 1 schema is selected, all tables from each of these schemas must be selected. (because mysqldump --databases option will be used in this case)
[1 Feb 2010 14:31] Johannes Taxacher
fix confirmed.
 will be included in 5.2.16
[5 Feb 2010 15:59] Tony Bedford
An entry has been added to the 5.2.16 changelog:

The data dump facility, used for exporting data to disk, has been modified to allow the --single-transaction option to be specified.

If --single-transaction is enabled, the table selection will be restricted the following ways:

1. If a single schema is selected, it is possible to select/deselect its tables as required.

2. If more than one schema is selected, all tables from these schemas must be selected, because mysqldump --databases will be used in this case.