Bug #49138 WB should stop on unknown cmdline options
Submitted: 26 Nov 2009 12:17 Modified: 28 Nov 2013 10:36
Reporter: Hartmut Holzgraefe Email Updates:
Status: Won't Fix Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:mysql-workbench 5.2.9 OS:Linux (Ubuntu 9.04 x86 .deb)
Assigned to: CPU Architecture:Any

[26 Nov 2009 12:17] Hartmut Holzgraefe
Description:
WB only prints a warning when given a commandline option it does not understand but continues to start up. IMHO it should print the warning as error and terminate with an error code instead.

Currently the warning is printed but scrolls out of the invoking terminal pretty fast due to all the other diagnostic output so it is easy to overlook it.

How to repeat:
mysql-workbench --unknown-option-name

Suggested fix:
Stop on unknown options.
[26 Nov 2009 14:01] MySQL Verification Team
Verified with 5.2.8 version.
[28 Nov 2013 10:36] Hartmut Holzgraefe
Seems to be fixed:

$ mysql-workbench --version
MySQL Workbench CE (GPL) 6.0.8 11354  build 833

$ mysql-workbench --foobar
/usr/bin/mysql-workbench-bin: Unknown option --foobar
[14 Sep 18:01] Omer Barnir
Posted by developer:

This issue applies to the legacy MySQL Workbench 8.x implementation that is no longer supported or maintained.
MySQL Workbench 26.7 is a complete rewrite using a new technology stack and does not use the affected legacy implementation.
Therefore, this issue is not applicable to the current MySQL Workbench product and as such is closed.