Bug #48822 "Toggle grid" and "Align objects to grid" toolbar buttons do not render properly
Submitted: 16 Nov 2009 22:59 Modified: 27 Nov 2009 15:27
Reporter: Craig Fowler Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.8 OS:Linux (Debian Squeeze x86/Ubuntu 9.04 .deb package)
Assigned to: Alfredo Kojima CPU Architecture:Any
Tags: toolbar, UI
Triage: Needs Triage: D3 (Medium)

[16 Nov 2009 22:59] Craig Fowler
Description:
Small visual-only glitch - doesn't affect functionality as far as I can see:

The "toggle grid" and "align objects to grid" buttons on the toolbar do not render correctly when they are in "selected" state.  The icons do not show and the button width is reduced.  When toggled 'off' the icons appear correctly.

Screenshot to follow ...

How to repeat:
Open a project, view an ER diagram, toggle the "Toggle grid" and/or "Align objects to grid" toolbar buttons.
[16 Nov 2009 23:03] Craig Fowler
The incorrectly-rendering toolbar icons

Attachment: wb-buttons-invisible.png (image/png, text), 33.01 KiB.

[16 Nov 2009 23:06] Craig Fowler
It just occurred to me that this info may or may not be relevant:

I am primarily using KDE on my desktop and my GTK settings are to use the "QtCurve" style by default and to "Use KDE fonts in GTK applications".

I don't *think* that this will make a difference but better to give too much info than too little ;)
[18 Nov 2009 14:04] Johannes Taxacher
verified just as described on a default ubuntu 9.04 box (standard gnome environment)
[25 Nov 2009 11:53] Johannes Taxacher
fixed in reporitory.
will be included in 5.2.9
[27 Nov 2009 15:27] Tony Bedford
An entry has been added to the 5.2.9 changelog:

In the EER Diagram view, the Toggle Grid and Align Objects to Grid toolbar buttons were not rendered correctly when in the selected state.