Bug #48818 Filter checkboxes in "Select Objects to Reverse Engineer" don't do anything
Submitted: 16 Nov 2009 20:05 Modified: 30 Dec 2009 16:54
Reporter: Yvan Rodrigues Email Updates:
Status: No Feedback Impact on me:
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.1.18 OS:Windows (XP Professional x64)
Assigned to: CPU Architecture:Any
Tags: checkbox, FUNCTION, objects, reverse engineer, schema, select objects, stored procedure, table, trigger, VIEW

[16 Nov 2009 20:05] Yvan Rodrigues
When filtering schema objects to import during reverse engineering, the user interface allows object types such as tables views to be deselected using a checkbox, but the checkbox doesn't do anything.

How to repeat:
- Database | Reverse Engineer (Ctrl-R)
- Continue to "Select Objects" screen
- Uncheck an object type (e.g. tables)
- Note that number of total vs. selected objects does not change. This is not only a UI issue -- if you try to proceed, it will use all "selected" objects.

Suggested fix:
Fix checkbox behaviour.
[24 Nov 2009 14:08] MySQL Verification Team
Thank you for the bug report. Which version are you using? Please try 5.2.8 if your version is older than it. Thanks in advance.
[24 Nov 2009 14:25] Yvan Rodrigues
Sorry, the version is 5.1.18. I haven't tried the beta version (yet).
[30 Nov 2009 16:54] Susanne Ebrecht
We are not able to repeat this with Workbench 5.2.8.

Did we misunderstood you or is it solved?
[1 Jan 2010 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".