Bug #48706 MySQL Migration Toolkit copies only a part of long identifiers names
Submitted: 11 Nov 2009 22:51 Modified: 13 Nov 2009 9:22
Reporter: Gian Franco Zabarino Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S2 (Serious)
Version:1.1.17 OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any
Tags: migration toolkit cut identifier name key convert migrate

[11 Nov 2009 22:51] Gian Franco Zabarino
Description:
The MySQL Migration Toolkit cut long identifiers names, I have a +200 tables MS SQL 2005 DB, with a lot of keys whose identifiers are very long, for example, 41 characters. For a key named "acCartasDePorte__porLocalidadDestinatario", when it convert the name to the new MySQL DB, it only shows "acCartasDePorte__porLocalidadDe". I found out that the maximum length of a key identifier is 64 bytes, so I don't understand why this is happening. I can fix the names that comes with duplicate key error, but there are a lot that don't throw any error at all, and yet they are cut. 

How to repeat:
Try to create a sample DB in MS SQL Server 2005, with a key name as mentioned above, and try to migrate it to a MySQL Server with MySQL Migration Toolkit.

Suggested fix:
I think that the maximum length of a identifier should be as documented, someone should take a look at that part of the code of MySQL Migration Toolkit.
[11 Nov 2009 23:17] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=48707 marked as duplicate of this one.
[13 Nov 2009 9:22] Susanne Ebrecht
Many thanks for writing a bug report.

Usually there is not problem on MySQL side with identifier length here.

The source of the problem is on MS SQL side.

We have had similar problem already here with Sybase.

Please read bug #22859