Bug #48682 CTRL-S don't work
Submitted: 11 Nov 2009 9:03 Modified: 27 Nov 2009 14:40
Reporter: Susanne Ebrecht Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[11 Nov 2009 9:03] Susanne Ebrecht
Description:
I worked on bug #47953 and found this issue:

1. Double clic on table in ER diagram
2. Modify varchar(n) to varchar(m)
3. * is apprears next to file name on MWB titlebar. '<filename.mwb> - MySQL Workbench'
4. Ctrl-S does not save file. '*' still appears.
5. Goto menu File --> Save File . File is saved.

How to repeat:
See above

Suggested fix:
...
[11 Nov 2009 9:05] Susanne Ebrecht
For making a deeper analysis here I would need the following informations because this works fine by using Workbench 5.2 on Linux.

1) Which OS (I guess Windows)
2) Which Workbench version
[11 Nov 2009 11:23] Susanne Ebrecht
We don't need feedback anymore.

Johannes was able to repeat this on Windows by using Workbench 5.2.

Verified as described.
[25 Nov 2009 11:31] Johannes Taxacher
this has been fixed in 5.2.8
[27 Nov 2009 14:40] Tony Bedford
An entry has been added to the 5.2.8 changelog:

When a table was edited in the EER Diagram view, and Ctrl+S was pressed to save the model, the model file was not saved.
[30 Nov 2009 11:05] Johannes Taxacher
Bug #45394 has been marked as duplicate of this one.