Bug #48520 cairo error: out of memory
Submitted: 4 Nov 2009 0:02 Modified: 18 Nov 2009 17:29
Reporter: Silvio Silva Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.6alpha OS:Windows (Windows 7)
Assigned to: Mike Lischke CPU Architecture:Any

[4 Nov 2009 0:02] Silvio Silva
I've noticed a 'cairo error: out of memory' when changing my screen resolution

System info
MySQL Workbench OSS for Windows version 5.2.6
Cairo Version: 1.8.6
Rendering Mode: OpenGL requested (create a diagram to confirm)
OpenGL Driver Version: 3.2.0
OS: unknown
CPU: 8x Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 6.0 GB RAM
Video adapter info:
Adapter type: NVIDIA GeForce GTX 260
Chip Type: GeForce GTX 260
BIOS String: Version
Video Memory: 917504 KB

How to repeat:
1. Open MySQL Workbench
2. Change Windows screen resolution
3. Mouse over Workbench sheet
[4 Nov 2009 10:45] Tonci Grgin
Hi Silvio and thanks for your report.

Two of us tried (real HW and VM) and both can't reproduce said problem on Win7 x64.

Personally, I tried from 1400x1050 to 800x600, nothing weird happened. I think this might be due to your configuration (both HW and drivers).

If you find any other way of reproducing this, please reopen the report.
[4 Nov 2009 12:58] Silvio Silva
I'll try on my laptop later, anyway on my desktop it only happens when I change to an higher one.

Eg. 1024:768 -> 1280:960
[4 Nov 2009 13:02] Tonci Grgin
Silvio, sorry for not being clear, I did go all the way back up from 800x600 to 1400x1050. Unfortunately, VirtualBox does not allow me to test *all* resolutions but if problem happens *only* at specific and single step I'd look into drivers.
[4 Nov 2009 14:08] Silvio Silva
I've tried to reproduce it with a smaller ERR (5 entities) and the error won't occur. It only happens with a certain ERR (20+ entities 20+ relationships), not sure if it's only on that ER or only on big ERRs
[14 Nov 2009 16:35] Daniel M
I've got the same problem on WindowsXP SP3 32bit. Same WB version.

It happens when the available space on the screen becomes bigger than the document size. So if your diagram and the zoom factor is small enough, it's enough to close the sidebar and open it again, for example. The "cairo: not enough memory" just keeps coming up, effectively rendering the program unusable. Didn't happen in 5.1.
[16 Nov 2009 8:03] Tonci Grgin
Daniel, this only shows how important it is to try and gather all of the data possible when filing bug report... When can I expect such document attached and exact screen resolution that will cause it to fail?
[16 Nov 2009 22:22] Silvio Silva
I was able to reproduce it on two other boxes w/different specs:
1. 'File' > 'New Model'
2. 'Model' > 'Add Diagram'
3. 'Model' > 'Diagram properties and size'
4. Set 'Width' & 'Height' to 1
5. Resize your working area to be bigger than the sheet
6. Do something (scroll, add object, etc)

Video at: http://www.youtube.com/watch?v=Yqks6twqrCw
[17 Nov 2009 8:57] Tonci Grgin
Thanks Silvio.

Verified just as described in Silvio's video... Further more, VirtualBox GUI crashed so badly that I wasn't able to recover it...
[17 Nov 2009 12:05] Mike Lischke
Fixed in 5.2 (rev 4542).
[17 Nov 2009 12:08] Tonci Grgin
Thanks Mike.
[18 Nov 2009 16:21] Johannes Taxacher
cannot get that err anymore after fixing. fix will be included in 5.2.8
[18 Nov 2009 17:29] Tony Bedford
An entry was added to the 5.2.8 changelog:

When running MySQL Workbench the following error occurred when an attempt was made to change the Windows screen resolution:

cairo error: out of memory