Bug #48065 Replication has been setup, but the data is not sync to
Submitted: 15 Oct 2009 4:03 Modified: 16 Oct 2009 9:30
Reporter: cheng cheng Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.4.1 OS:Microsoft Windows (server 2003)
Assigned to: CPU Architecture:Any

[15 Oct 2009 4:03] cheng cheng
Description:
The replication traverses different network segment. Master server MySQL 5.4.1 is in HK, slave server MySQL 6.0.5 is in Singapore. The replication appears running with both IO and SQL process running. But when some modification occurs in maser, the data of slave is not sync to.  error info in *.ver is below:

091015 10:36:22 [ERROR] Error reading packet from server: Lost connection to MySQL server during query ( server_errno=2013)
091015 10:36:22 [Note] Slave I/O thread killed while reading event
091015 10:36:22 [Note] Slave I/O thread exiting, read up to log 'mysql-bin-uctol.000002', position 6166
091015 10:36:22 [Note] Error reading relay log event: slave SQL thread was killed
091015 10:37:37 [Note] Slave SQL thread initialized, starting replication in log 'mysql-bin-uctol.000002' at position 6166, relay log '.\boon-relay-bin.000001' position: 4
091015 10:37:40 [Note] Slave I/O thread: connected to master 'nbarep@203.142.94.5:3306',replication started in log 'mysql-bin-uctol.000002' at position 6166

More puzzle thing is: When i checked the slave status the Read_Master_Log_Pos is the same with master server. Actually it seems the slave fail to get data packet from server, but get the position info from server. All the time, the slave can keep pace with master, but the data is not sync to.

I have tested the same situation in the same network segment. It works all right. Is possible the network problem? Then i check the port in master server, the default port we using is open. And there is no skip-networking option in my configuration. The slave can also ping to master. So then, what is the problem it may be?

How to repeat:
Master server my.ini:
-----------------------------
server-id=1
binlog_format=mixed
log-bin=mysql-bin-uctol.log
binlog-do-db=uctol
wait_timeout=604800
--------------------------------

Slave server my.ini:
------------------------------
server-id=5
replicate-do-table=’uctol.accouts’
replicate-do-table=’uctol.leaderboard’
replicate-do-table=’uctol.addr’

========================================
[15 Oct 2009 10:48] Susanne Ebrecht
This looks more like a tcp timeout for me.

Can you ping the master?
[16 Oct 2009 1:48] cheng cheng
Yes, the slave can ping to master
[16 Oct 2009 9:27] cheng cheng
The problem is clarified. The single quotes in my.ini should be change from ‘to '.
[16 Oct 2009 9:30] Valeriy Kravchuk
So this problem was not a result of any bug in MySQL code.