Bug #48041 Restoring
Submitted: 14 Oct 2009 14:46 Modified: 17 Nov 2009 14:32
Reporter: Jack Shultz Email Updates:
Status: No Feedback Impact on me:
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.0.77 OS:Linux (RH5)
Assigned to: CPU Architecture:Any
Tags: removed mysql packages

[14 Oct 2009 14:46] Jack Shultz
By accident i removed mysql packages from the wrong computer. Now when I restored the mysql packages using yum. I cannot start mysql. I tried running
libexec]# ./mysqld --innodb_file_io_threads=6
It produced a page full of zeros and then this information at the end.

I could restore from a snapshot taken in July but I will be missing quite a bit of data.

                                  ;InnoDB: End of page dump
091014  7:44:44  InnoDB: Page checksum 1575996416, prior-to-4.0.14-form checksum 1371122432
InnoDB: stored checksum 0, prior-to-4.0.14-form stored checksum 0
InnoDB: Page lsn 0 0, low 4 bytes of lsn at page end 0
InnoDB: Page number (if stored to page already) 0,
InnoDB: space id (if created with >= MySQL-4.1.1 and stored already) 0
091014  7:44:44InnoDB: Error: trying to access a stray pointer 0x80002aaaab02fff8
InnoDB: buf pool start is at 0x2aaaab020000, end at 0x2aaaab820000
InnoDB: Probable reason is database corruption or memory
InnoDB: corruption. If this happens in an InnoDB database recovery, see
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/forcing-recovery.html
InnoDB: how to force recovery.
091014  7:44:44InnoDB: Assertion failure in thread 47331809438160 in file ./../include/buf0buf.ic line 268
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/forcing-recovery.html
InnoDB: about forcing recovery.
091014  7:44:44 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_connections = 217599 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
frame pointer is NULL, did you compile with
-fomit-frame-pointer? Aborting backtrace!
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
[root@hydrogenathome libexec]#

How to repeat:
By accident i removed mysql packages from the wrong computer. Now when I restored the mysql packages using yum. I cannot start mysql. I tried running
libexec]# ./mysqld --innodb_file_io_threads=6
[17 Oct 2009 14:32] Valeriy Kravchuk
Please, send your my.cnf file content. Check also logs as the OS level (/var/log/messages etc) for hardware-related error messages.

Send the results of:

find / -name "ibdata1" 2>/dev/null
[18 Nov 2009 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".