Bug #4793 MYSQL has no support for Windows 2003 Server
Submitted: 28 Jul 2004 17:49 Modified: 31 Jul 2004 21:17
Reporter: [ name withheld ] Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:4.20 OS:Microsoft Windows (Windows 2003 Server)
Assigned to: CPU Architecture:Any

[28 Jul 2004 17:49] [ name withheld ]
Description:
MYSQL Service Starts for approx 2 seconds before turning itself off again. Adding my.cnf into root of drive doesn't work as suggested in the manual.

How to repeat:
Install MYSQL onto Windows 2003 Server. Attempt to start. Fails.

Suggested fix:
No Idea!!!
[31 Jul 2004 9:53] MySQL Verification Team
I installed the MySQL service on Windows 2003 Server, started it and 
connected with the mysql client:

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

c:\mysql\bin>mysqld-nt --install-manual
Service successfully installed.

c:\mysql\bin>net start mysql
The MySQL service is starting.
The MySQL service was started successfully.

c:\mysql\bin>mysql -uroot
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 4.0.20a-nt

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>

Please read the below intructions in the MySQL Manual:

2.2.1 Installing MySQL on Windows
http://dev.mysql.com/doc/mysql/en/Windows_installation.html

2.2.1.7 Starting MySQL as a Windows Service
http://dev.mysql.com/doc/mysql/en/NT_start.html
[31 Jul 2004 11:33] [ name withheld ]
Thanks - I think the problem lies in WinMYSQLAdmin Tool. As soon as you use it, everything stops working and you receive error 1067 when trying to access the service via the services manager in Computer Management.

Now running okay using my.cnf and NO WinMYSQLAdmin. For others - beware that it auto installs into Startup folder when you run it. If you want to test your connection, use something different!
[31 Jul 2004 19:49] MySQL Verification Team
WinMySQLAdmin on Windows 2003 Server

Attachment: winmysqladmin.JPG (image/jpeg, text), 123.16 KiB.

[31 Jul 2004 19:54] MySQL Verification Team
I tested WinmySQLAdmin on Windows 2003 Server and it works, please
see the picture winmysqladmin.jpg I attached to this bug report using
the tab Files.

However you aren't the first user which reports having problems to start
WinMySQLAdmin on Windows 2003 Server, unlucky until now I wasn't able
to repeat the issue on my machine and in this way I can't to fix it.

Thanks for your comments.
[31 Jul 2004 20:09] [ name withheld ]
Doesn't work at all! Doesn't start, then when I look at it, it comes up Error 1067. Have you tried accessing the service via the Service Manager?

Most of the problems people have had (in General) is where the dll file need copying to the system32 directory, however under win2k3, many people have had the same issues as us.

What worked for us was not using WinMYSQLAdmin, but only after installing a pile of MS updates. Perhaps that's it? We bought it when it was brand new. Do you have a later edition?
[31 Jul 2004 21:17] MySQL Verification Team
> Doesn't work at all! Doesn't start, then when I look at it, it comes up
> Error 1067. Have you tried accessing the service via the Service
> Manager?

Yes I tested through the command prompt, with WinMySQLAdmin and
the Service Manager.

> Most of the problems people have had (in General) is where the dll file
> need copying to the system32 directory, however under win2k3, many
> people have had the same issues as us.

Yes, but this was a bug with our installer and already fixed in the current
packages placing the libmysql.dll in the same location of WinMySQLAdmin.
I think that our installer should avoid to place the libmysql.dll in the system32
directory because it can re-written an libmysql.dll with a major version, so the
user needs to do the (re-)place knowing what is doing.

> What worked for us was not using WinMYSQLAdmin, but only after
> installing a pile of MS updates. Perhaps that's it? We bought it when
> it was brand new. Do you have a later edition?

Yes it is a recent edition I bought it around 4 weeks ago and until now I
didn't applied any update because I use it just to test bug reports, my
machine is multi-boot with Linux Fedora Core 2, Windows 2000 Server,
Windows 2003 Server and XP Home Edition. However I will get the updates
and to make test, because we had already experiences with updates that
affects our products e.g: the XP with SP 1 affects the MyODBC performance
and the work around is to set the DSN with Don't use set locale.

The error 1067 generally means that the MySQL server has aborted for
some reason, most frequently for bad configuration keys in my.cnf/my.ini
file.