Bug #47801 The plugin test fails with the Embedded Server on Windows
Submitted: 2 Oct 2009 20:09 Modified: 18 Dec 2009 23:42
Reporter: Igor Babaev Email Updates:
Status: Closed Impact on me:
None 
Category:Tools: MTR / mysql-test-run Severity:S3 (Non-critical)
Version:5.1 OS:Microsoft Windows
Assigned to: Magnus Blåudd CPU Architecture:Any

[2 Oct 2009 20:09] Igor Babaev
Description:
When working on Windows with the build created from the current mysql-5.1 tree 
(http://bazaar.launchpad.net/~mysql/mysql-server/mysql-5.1/) and trying to run

mysql-5.1\mysql-test>perl mysql-test-run.pl --embedded-server plugin

I've got an unexpected result.

How to repeat:
Install MySQL from the build tree on Windows following the instructions that could be found in win/README (do not forget to include the Embedded Server
whe executing win\configure.js).

Run 

mysql-5.1\mysql-test>perl mysql-test-run.pl --embedded-server plugin

You'll get something like this:

C:\mysql-5.1\mysql-test>perl mysql-test-run.pl --embedded-server plugin
Logging: mysql-test-run.pl  --embedded-server plugin
MySQL Version 5.1.40
Checking supported features...
 - skipping ndbcluster
 - skipping SSL
 - binaries are debug compiled
Collecting tests...
vardir: C:/mysql-5.1/mysql-test/var
Checking leftover processes...
Removing old var directory...
Creating var directory 'C:/mysql-5.1/mysql-test/var'...
Installing system database...
Using server port 2542

==============================================================================

TEST                                      RESULT   TIME (ms)
------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
worker[1] mysql-test-run: *** ERROR: .opt file references 'EXAMPLE_PLUGIN_OPT' which is not set
[3 Oct 2009 0:03] MySQL Verification Team
On Vista 64-bit:

c:\build\mysql-5.1-embedded\mysql-test>perl mysql-test-run.pl --embedded-server plugin
Found handle.exe version 3.42
Logging: mysql-test-run.pl  --embedded-server plugin
091002 21:01:58 [Note] Plugin 'FEDERATED' is disabled.
091002 21:01:58 [Warning] Forcing shutdown of 1 plugins
MySQL Version 5.1.40
Checking supported features...
 - skipping ndbcluster
 - skipping SSL
 - binaries are debug compiled
Collecting tests...
vardir: c:/build/mysql-5.1-embedded/mysql-test/var
Removing old var directory...
Creating var directory 'c:/build/mysql-5.1-embedded/mysql-test/var'...
Installing system database...
Using server port 50288

==============================================================================

TEST                                      RESULT   TIME (ms)
------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
worker[1] mysql-test-run: *** ERROR: .opt file references 'EXAMPLE_PLUGIN_OPT' which is not set

c:\build\mysql-5.1-embedded\mysql-test>
[3 Oct 2009 0:07] MySQL Verification Team
Thank you for the bug report.
[4 Oct 2009 20:41] Sergey Petrunya
Same issue as BUG#47812.
[5 Oct 2009 3:26] Valeriy Kravchuk
Bug #47812 was marked as a duplicate of this one,
[8 Oct 2009 8:39] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/86098
[8 Oct 2009 8:41] Magnus Blåudd
Reviewed on IRC
[8 Oct 2009 8:41] Magnus Blåudd
Pushed to 5.1-mtr
[22 Oct 2009 20:17] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091022201524-0efl2fzebfuuf0vk) (version source revid:bjorn.munch@sun.com-20091008122436-bqmy3lmr9iaw4d4s) (merge vers: 6.0.14-alpha) (pib:13)
[22 Oct 2009 20:18] Bugs System
Pushed into 5.5.0-beta (revid:alik@sun.com-20091022201318-jfvtrzd6lb07cwp5) (version source revid:bjorn.munch@sun.com-20091008093442-or0trmzmb2pqcyk7) (merge vers: 5.4.5-beta) (pib:13)
[22 Oct 2009 23:16] Paul DuBois
Test suite change. No changelog entry needed.

Setting report to NDI pending push into 5.1.x.
[23 Oct 2009 7:34] Bugs System
Pushed into 5.1.41 (revid:bjorn.munch@sun.com-20091021073307-ummbh6668hvfxqjv) (version source revid:bjorn.munch@sun.com-20091021073307-ummbh6668hvfxqjv) (merge vers: 5.1.41) (pib:13)
[23 Oct 2009 15:16] Paul DuBois
Test suite change. No changelog entry needed.
[18 Dec 2009 10:34] Bugs System
Pushed into 5.1.41-ndb-7.1.0 (revid:jonas@mysql.com-20091218102229-64tk47xonu3dv6r6) (version source revid:jonas@mysql.com-20091218095730-26gwjidfsdw45dto) (merge vers: 5.1.41-ndb-7.1.0) (pib:15)
[18 Dec 2009 10:50] Bugs System
Pushed into 5.1.41-ndb-6.2.19 (revid:jonas@mysql.com-20091218100224-vtzr0fahhsuhjsmt) (version source revid:jonas@mysql.com-20091217101452-qwzyaig50w74xmye) (merge vers: 5.1.41-ndb-6.2.19) (pib:15)
[18 Dec 2009 11:05] Bugs System
Pushed into 5.1.41-ndb-6.3.31 (revid:jonas@mysql.com-20091218100616-75d9tek96o6ob6k0) (version source revid:jonas@mysql.com-20091217154335-290no45qdins5bwo) (merge vers: 5.1.41-ndb-6.3.31) (pib:15)
[18 Dec 2009 11:19] Bugs System
Pushed into 5.1.41-ndb-7.0.11 (revid:jonas@mysql.com-20091218101303-ga32mrnr15jsa606) (version source revid:jonas@mysql.com-20091218064304-ezreonykd9f4kelk) (merge vers: 5.1.41-ndb-7.0.11) (pib:15)