Bug #47522 Failed make test on main.not_partition
Submitted: 22 Sep 2009 14:58 Modified: 3 Nov 2009 9:57
Reporter: imacat . (Basic Quality Contributor) Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Partitions Severity:S2 (Serious)
Version:5.1.39 OS:Linux (2.6.26)
Assigned to: Mattias Jonsson CPU Architecture:Any
Tags: main.not_partition, qc

[22 Sep 2009 14:58] imacat .
    Hi.  This is imacat from Taiwan.  I have downloaded and tried to compile the newly-released MySQL 5.1.39.  make test failed at main.not_partition.

    I tried it on 2 environments, and both failed at the same place with the same output.  They are: Debian GNU/Linux 5.0.3 Lenny, Linux kernel 2.6.26, gcc 4.3.2, glibc 2.7, with one x86_64 and the other i686.

    The failed output is posted below.  Hope this helps.  Please tell us if there is any problem, or if you need any more environment.

imacat@rinse src/mysql-5.1.39 % make test
Running tests: mytap mysys ../storage/archive ../storage/blackhole ../storage/csv ../storage/example ../storage/federated ../storage/heap ../storage/innobase ../storage/innodb_plugin ../storage/myisam ../storage/myisammrg ../plugin/daemon_example ../plugin/fulltext
mytap/t/basic-t .... ok
mysys/bitmap-t ..... ok
mysys/my_atomic-t .. ok
mysys/base64-t ..... ok
All tests successful.
Files=4, Tests=3032,  6 wallclock secs ( 0.57 usr  0.00 sys +  2.90 cusr  0.03 csys =  3.50 CPU)
Result: PASS
Logging: ./mysql-test-run.pl  --mysqld=--binlog-format=mixed
MySQL Version 5.1.39
Using binlog format 'mixed'
Checking supported features...
 - skipping ndbcluster, mysqld not compiled with ndbcluster
 - skipping SSL, mysqld not compiled with SSL
Collecting tests...
 - adding combinations for binlog
 - adding combinations for rpl
vardir: /usr/local/src/mysql-5.1.39/mysql-test/var
Removing old var directory...
Creating var directory '/usr/local/src/mysql-5.1.39/mysql-test/var'...
Installing system database...
Using server port 49821


TEST                                      RESULT   TIME (ms)

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
binlog.binlog_multi_engine               [ skipped ]  No ndbcluster support
main.not_embedded_server                 [ pass ]      2
main.not_partition                       [ fail ]
        Test ended at 2009-09-22 22:48:55

CURRENT_TEST: main.not_partition
mysqltest: At line 18: command "copy_file" failed with wrong error: 1

The result from queries just before the failure was:

 - saving '/usr/local/src/mysql-5.1.39/mysql-test/var/log/main.not_partition/' to '/usr/local/src/mysql-5.1.39/mysql-test/var/log/main.not_partition/'

Only  604  of 896 completed.
mysql-test-run: *** ERROR: Not all tests completed
make: *** [test-ns] Error 1
You have new mail.
imacat@rinse src/mysql-5.1.39 %

How to repeat:
% ./Configure
% make
% make test
[22 Sep 2009 15:00] imacat .
Log files for main.not_partition

Attachment: var-main.not_partition.tar.bz2 (application/octet-stream, text), 460.87 KiB.

[22 Sep 2009 20:51] Sveta Smirnova
Thank you for the report.

Verified as described.
[23 Oct 2009 23:49] Mattias Jonsson
Seems like the pre-generated table files used by the test is not distributed in the source distribution package. The test works if one uses the code directly from bazaar.
[3 Nov 2009 9:36] Mattias Jonsson
The source package of 5.1.39 does not set up std_data_ln symlink in mysql-test/var (should point to mysql-test/std_data).

in 5.1.40 the symlink exists again.

I will update the working not_partition.test to use 'std_data' instead of '$MYSQLD_VARDIR/std_data_ln'.
[3 Nov 2009 9:57] Mattias Jonsson
This was already fixed in 5.1.40, changed from using std_data_ln to std_data.

Will not change the test further, closing bug.