Bug #475 big_sql_selects does not work
Submitted: 21 May 2003 10:48 Modified: 30 Jun 2003 10:08
Reporter: [ name withheld ] Email Updates:
Status: Closed Impact on me:
None 
Category:MySQLCC Severity:S2 (Serious)
Version:0.9.2 OS:Microsoft Windows (Windows 2000)
Assigned to: Bugs System CPU Architecture:Any

[21 May 2003 10:48] [ name withheld ]
Description:
I have been having this problem since 0.9.1 (the first version of mysqlcc that I've tried).  When I double-click on a table from the tree view, I get the following in the messages at the bottom of the screen:

[localhost] ERROR 1104: The SELECT would examine too many records and probably take a very long time. Check your WHERE and use SET OPTION SQL_BIG_SELECTS=1 if the SELECT is ok

This is despite the fact that the appropriate options are already set in the Query Configuration Dialog.  If I try to specify it manually as part of the SQL query, the set statement executes fine but I still get the error.

If I do a select * from <table>, using the command-line mysql, it runs fine.

This problem seems to occur regardless of which table I try to view.  Table complexity doesn't seem to be a factor, although it seems that this problem does NOT occur if I have less than 2 rows in a given table.

How to repeat:
Navigating the tree view on the left side, open a table by double-clicking on it.

Suggested fix:
Hell if I know.
[30 May 2003 16:20] [ name withheld ]
I am experiencing the same issues.  I am using the latest versions of everything (MySQL 4.0.13 and MyCC 0.92).

The difference I found is that you **must** be on the same computer as the database is on.  Running MyCC on a different machine will not get the same errors.  Also, the error seems not to happen right away and will not happen on empty tables.

My database/MyCC is currently having this issue so you can E-mail me if you need a build tested.

System configs:
OS: Windows 2003 Server
Processor: P4 3.06
MySQL Ver: 4.0.13
MyCC Ver: 0.92
[18 Jun 2003 2:34] Martin Purdy
I have the same problem with the database and the control centre on the same PC.
the sql "SET OPTION SQL_BIG_SELECTS=1;SELECT * FROM mytable" returns the error.
Once the table has more than one record this error occurs.

MysqlManager has no problems.

I have reported another bug report in the hope of escalating this.
[30 Jun 2003 10:08] Jorge del Conde
Hi!

This bug was fixed in 0.9.2.  The reason why you're still experiencing this in 0.9.2 is because MySQLCC is using the "buggy" server configuration files which where created by 0.9.1.  To fix this, edit the server properties, to the "MySQL Options" tab and change the "Max Join Size" option to 1000000.  You can also delete the server and create a new one and that will fix the buggy default values introduced in 0.9.1

Thanks for the bug report