Bug #4699 Number of SQL queries not shown in transactions
Submitted: 22 Jul 2004 16:56 Modified: 22 Jul 2004 19:35
Reporter: Giovanni Acerbi Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.0.7 beta OS:Microsoft Windows (MS Windows 2000 Professional)
Assigned to: Michael G. Zinner CPU Architecture:Any

[22 Jul 2004 16:56] Giovanni Acerbi
Description:
The Number of SQL Queries in the Connection Health section is not shown if the queries are executed in a transaction.

I found it while testing an ASP.NET application. I tried it in all the available isolation levels (Chaos is not supported).

My operating system is Windows 2000 professional but MySql Administrator was connected to a remote Windows 2003 Server (where my application resides) with MySql Connector/ODBC 3.51.06 and MySql Server 4.0.18 installed.

Please let me know if this is by design.
Best regards.
Giovanni Acerbi.

How to repeat:
Simply refresh the ASP.NET page, queries are executed but the number of queries is not shown.
[22 Jul 2004 19:35] Michael G. Zinner
We do execute the SHOW STATUS command to get the statistic values from the server. So the issue is not caused by the MySQL Administrator. To get more details you can go to the Status Variables tabsheet and check the Commands executed/DML.

The formula used to display a graph uses these values. To edit the formula use the right mousebutton.