Bug #46952 backup_logs fails on Valgrind platform in PB2
Submitted: 27 Aug 2009 12:14 Modified: 4 Sep 2009 11:23
Reporter: Jørgen Løland Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tools Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any
Triage: Triaged: D2 (Serious)

[27 Aug 2009 12:14] Jørgen Løland
Description:
backup_logs test fails consistently on Valgrind in PB2:

backup.backup_logs                       w8 [ fail ]
        Test ended at 2009-08-21 03:23:43

CURRENT_TEST: backup.backup_logs
==10455== Memcheck, a memory error detector.
==10455== Copyright (C) 2002-2006, and GNU GPL'd, by Julian Seward et al.
==10455== Using LibVEX rev 1658, a library for dynamic binary translation.
==10455== Copyright (C) 2004-2006, and GNU GPL'd, by OpenWorks LLP.
==10455== Using valgrind-3.2.1, a dynamic binary instrumentation framework.
==10455== Copyright (C) 2000-2006, and GNU GPL'd, by Julian Seward et al.
==10455== For more details, rerun with: -v
==10455== 
==10455== Conditional jump or move depends on uninitialised value(s)
==10455==    at 0x47BC68: DoTrace (dbug.c:1761)
==10455==    by 0x47AC9D: _db_enter_ (dbug.c:1184)
==10455==    by 0x458A3F: LogFile::write(st_dynamic_string*) (mysqltest.cc:551)
==10455==    by 0x45825C: main (mysqltest.cc:8113)
{
   <insert a suppression name here>
   Memcheck:Cond
   fun:DoTrace
   fun:_db_enter_
   fun:_ZN7LogFile5writeEP17st_dynamic_string
   fun:main
}
==10455== 
==10455== Conditional jump or move depends on uninitialised value(s)
==10455==    at 0x47BC68: DoTrace (dbug.c:1761)
==10455==    by 0x47AE55: _db_return_ (dbug.c:1253)
==10455==    by 0x458A7F: LogFile::write(st_dynamic_string*) (mysqltest.cc:555)
==10455==    by 0x45825C: main (mysqltest.cc:8113)
{
   <insert a suppression name here>
   Memcheck:Cond
   fun:DoTrace
   fun:_db_return_
   fun:_ZN7LogFile5writeEP17st_dynamic_string
   fun:main
}
<much more like this>

How to repeat:
See valgrind platform in PB2 for the mysql-6.0-backup tree

Suggested fix:
No suggestion yet.
[27 Aug 2009 21:05] Chuck Bell
I cannot verify this. I have tried on two machines and do not see this problem. Also, it appears to be a mysqltest problem and not the backup code. Perhaps there is something in the mysqltest code that is causing the problem?

Reassigning to tests category. Can be reassigned to backup if the problem is indeed in the backup code but the valgrind stack does not indicate that.
[27 Aug 2009 21:05] Chuck Bell
oops.
[1 Sep 2009 14:45] Ingo Strüwing
I think it is better to always have a lead assigned to a verified bug report.
[4 Sep 2009 11:23] Bjørn Munch
Duplicate of Bug #45932