Bug #46859 MySQL Crashed
Submitted: 21 Aug 2009 18:10 Modified: 21 Aug 2009 18:32
Reporter: Aby John Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.1.11 OS:Other (CentOS 5.0.3)
Assigned to:

[21 Aug 2009 18:10] Aby John
Description:
MySQL database crashed. The error log can find below,

090820  3:18:54  InnoDB: Assertion failure in thread 1076947264 in file row/row0mysql.c line 1534
InnoDB: Failing assertion: index->type & DICT_CLUSTERED
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
090820  3:18:54 - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=268435456
read_buffer_size=1048576
max_used_connections=20
max_threads=500
threads_connected=19
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 1803233 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x18bbb9e0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0x4030df20 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x2e)[0x84622e]
/usr/sbin/mysqld(handle_segfault+0x322)[0x5bcd42]
/lib64/libpthread.so.0[0x328e00e4c0]
/lib64/libc.so.6(gsignal+0x35)[0x328d430215]
/lib64/libc.so.6(abort+0x110)[0x328d431cc0]
/usr/sbin/mysqld[0x7a8438]
/usr/sbin/mysqld(row_search_for_mysql+0x2461)[0x7b4c81]
/usr/sbin/mysqld(_ZN11ha_innobase10index_readEPhPKhj16ha_rkey_function+0x1cd)[0x72ce1d]
/usr/sbin/mysqld(_ZN7handler16read_range_firstEPK12st_key_rangeS2_bb+0xbe)[0x693dee]
/usr/sbin/mysqld(_ZN7handler22read_multi_range_firstEPP18st_key_multi_rangeS1_jbP17st_handler_buffer+0xd3)[0x693f13]
/usr/sbin/mysqld(_ZN18QUICK_RANGE_SELECT8get_nextEv+0x139)[0x6800f9]
/usr/sbin/mysqld[0x68f8d1]
/usr/sbin/mysqld(_Z12mysql_updateP3THDP10TABLE_LISTR4ListI4ItemES6_PS4_jP8st_ordery15enum_duplicatesb+0xf65)[0x647bf5]
/usr/sbin/mysqld(_Z21mysql_execute_commandP3THD+0x1447)[0x5caef7]
/usr/sbin/mysqld(_Z11mysql_parseP3THDPKcjPS2_+0x1f1)[0x5cf411]
/usr/sbin/mysqld(_Z16dispatch_command19enum_server_commandP3THDPcj+0xfd0)[0x5d0400]
/usr/sbin/mysqld(_Z10do_commandP3THD+0xe4)[0x5d0994]
/usr/sbin/mysqld(handle_one_connection+0x6ef)[0x5c3c1f]
/lib64/libpthread.so.0[0x328e006367]
/lib64/libc.so.6(clone+0x6d)[0x328d4d2f7d]
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 0x18c65d70 = UPDATE JOB_SANDBOX SET RUN_BY_INSTANCE_ID = 'ofbiz1', STATUS_ID = 'SERVICE_QUEUED' WHERE ((RUN_TIME <= '2009-08-20 03:15:02.888' AND START_DATE_TIME IS NULL AND CANCEL_DATE_TIME IS NULL AND RUN_BY_INSTANCE_ID IS NULL) AND (POOL_ID IS NULL OR POOL_ID = 'pool'))
thd->thread_id=786
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
090820 03:18:54 mysqld_safe mysqld from pid file /var/lib/mysql/FiO-VM3.pid ended

How to prevent the database crash?

How to repeat:
I cannot recreate the issue because MySQL having production databases.
[21 Aug 2009 18:32] Miguel Solorzano
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=45357