Bug #46745 MySQL crashes with InnoDB 1.0.4 plugin installed
Submitted: 16 Aug 2009 14:54 Modified: 17 Aug 2009 12:02
Reporter: Albert Mavashev Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB Plugin storage engine Severity:S1 (Critical)
Version:5.1.37 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: InnoDB 1.0.4 crash

[16 Aug 2009 14:54] Albert Mavashev
Description:
MySQL Server crashes after a while. Here is the log entry:

090815 21:35:08 [Note] Plugin 'FEDERATED' is disabled.
090815 21:35:16 [Note] Event Scheduler: Loaded 0 events
090815 21:35:16 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.37-community-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
090816  0:23:43 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=2147483648
read_buffer_size=2097152
max_used_connections=21
max_threads=160
threads_connected=19
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 853398 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x7d836e50
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
0000000180056A9D    ha_innodb.dll!???
00000001800574CB    ha_innodb.dll!???
000000018009D7B2    ha_innodb.dll!???
00000001800A0D3D    ha_innodb.dll!???
000000018007D90B    ha_innodb.dll!???
0000000180079487    ha_innodb.dll!???
000000014004EB5C    mysqld.exe!handler::read_range_first()[handler.cc:4186]
000000014004C553    mysqld.exe!handler::read_multi_range_first()[handler.cc:4060]
000000014010DBE4    mysqld.exe!QUICK_RANGE_SELECT::get_next()[opt_range.cc:8468]
0000000140122C46    mysqld.exe!rr_quick()[records.cc:313]
0000000140219387    mysqld.exe!mysql_update()[sql_update.cc:573]
00000001401A5535    mysqld.exe!mysql_execute_command()[sql_parse.cc:3026]
00000001401401C8    mysqld.exe!sp_instr_stmt::exec_core()[sp_head.cc:2908]
0000000140143975    mysqld.exe!sp_lex_keeper::reset_lex_and_exec_core()[sp_head.cc:2735]
0000000140143B76    mysqld.exe!sp_instr_stmt::execute()[sp_head.cc:2851]
00000001401455A5    mysqld.exe!sp_head::execute()[sp_head.cc:1255]
000000014014696F    mysqld.exe!sp_head::execute_procedure()[sp_head.cc:1983]
00000001401A7784    mysqld.exe!mysql_execute_command()[sql_parse.cc:4358]
00000001401A99E6    mysqld.exe!mysql_parse()[sql_parse.cc:5936]
00000001401AA71A    mysqld.exe!dispatch_command()[sql_parse.cc:1215]
00000001401AB7E7    mysqld.exe!do_command()[sql_parse.cc:854]
000000014024E677    mysqld.exe!handle_one_connection()[sql_connect.cc:1127]
00000001402C0235    mysqld.exe!pthread_start()[my_winthread.c:85]
00000001403D4057    mysqld.exe!_callthreadstart()[thread.c:295]
00000001403D4125    mysqld.exe!_threadstart()[thread.c:275]
0000000076E9BE3D    kernel32.dll!BaseThreadInitThunk()
0000000076FD6A51    ntdll.dll!RtlUserThreadStart()
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 00000000EA7FF1F0=UPDATE tw_logical_unit_work SET session_id            =  NAME_CONST('sessid',1), res_mgr_id            =  NAME_CONST('rmgrid',1), luw_type              = CASE WHEN  NAME_CONST('l_type',0) = 0 OR luw_type = 2 THEN luw_type ELSE  NAME_CONST('l_type',0) END, luw_status            = CASE WHEN  NAME_CONST('l_status',0) <= 0 THEN luw_status ELSE  NAME_CONST('l_status',0) END, luw_appl_pid          = COALESCE( NAME_CONST('l_pid',3748),luw_appl_pid), luw_appl_tid          = COALESCE( NAME_CONST('l_tid',4),luw_appl_tid), luw_start_time        = CASE WHEN  NAME_CONST('l_do_update',1) <> 0 THEN CASE WHEN TIMESTAMPDIFF(FRAC_SECOND, DATE_ADD( NAME_CONST('l_stime',_binary'2009-08-15 23:59:48' COLLATE 'binary'), INTERVAL  NAME_CONST('l_stime_usec',891523) MICROSECOND), DATE_ADD(luw_start_time, INTERVAL luw_start_time_usec MICROSECOND)) > 0 THEN  NAME_CONST('l_stime',_binary'2009-08-15 23:59:48' COLLATE 'binary') ELSE luw_start_time END ELSE COALESCE( NAME_CONST('l_stime',_binary'2009-08-15 23:59:48' COLLATE 'binary'),luw_st
thd->thread_id=16382
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
Writing a core file
Minidump written to C:\ProgramData\MySQL\MySQL Server 5.1\Data\mysqld.dmp

How to repeat:
Not sure.
[17 Aug 2009 6:31] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of bug #46676
[17 Aug 2009 12:02] Albert Mavashev
the crash stack trace of the duplicate issue looks completely different. Both issues might be related, but does not seem like a duplicate.