Bug #46721 Uncatched exception at 'export create script'
Submitted: 14 Aug 2009 13:59 Modified: 14 Aug 2009 14:04
Reporter: moi meme Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.1.16 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[14 Aug 2009 13:59] moi meme
Description:
Uncatched exception at 'export create script'.

Consultez la fin de ce message pour plus de détails sur l'appel du débogage
juste-à-temps (JIT) à la place de cette boîte de dialogue.

************** Texte de l'exception **************
System.AccessViolationException: Tentative de lecture ou d'écriture de mémoire protégée. Cela indique souvent qu'une autre mémoire est endommagée.
   à sigc.internal.signal_emit0<void,sigc::nil>.emit(signal_impl* impl)
   à sigc.signal0<void,sigc::nil>.emit(signal0<void\,sigc::nil>* )
   à mforms.Wizard.next_clicked(Wizard* )
   à MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   à System.Windows.Forms.Control.OnClick(EventArgs e)
   à System.Windows.Forms.Button.OnClick(EventArgs e)
   à System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.ButtonBase.WndProc(Message& m)
   à System.Windows.Forms.Button.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Assemblys chargés **************
mscorlib
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MySQLWorkbench
    Version de l'assembly : 5.1.16.4210
    Version Win32 : 5.1.16.4210
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/MySQLWorkbench.exe
----------------------------------------
wbprivate.wr
    Version de l'assembly : 0.0.0.0
    Version Win32 : 
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/wbprivate.wr.DLL
----------------------------------------
wbpublic.wr
    Version de l'assembly : 0.0.0.0
    Version Win32 : 
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/wbpublic.wr.DLL
----------------------------------------
System.Windows.Forms
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
MySQLCsUtilities
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/MySQLCsUtilities.DLL
----------------------------------------
msvcm90
    Version de l'assembly : 9.0.30729.1
    Version Win32 : 9.00.30729.1
    CodeBase : file:///C:/WINDOWS/WinSxS/x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.1_x-ww_6f74963e/msvcm90.dll
----------------------------------------
MySQLGrtShell
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/MySQLGrtShell.EXE
----------------------------------------
WeifenLuo.WinFormsUI.Docking
    Version de l'assembly : 2.2.3468.29126
    Version Win32 : 2.2.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/WeifenLuo.WinFormsUI.Docking.DLL
----------------------------------------
System.Configuration
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
WbPlugins
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/WbPlugins.DLL
----------------------------------------
Aga.Controls
    Version de l'assembly : 1.6.0.0
    Version Win32 : 1.6.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/Aga.Controls.DLL
----------------------------------------
System.Windows.Forms.resources
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms.resources/2.0.0.0_fr_b77a5c561934e089/System.Windows.Forms.resources.dll
----------------------------------------
grt.db.fe
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/grt.db.fe.DLL
----------------------------------------
mscorlib.resources
    Version de l'assembly : 2.0.0.0
    Version Win32 : 2.0.50727.3053 (netfxsp.050727-3000)
    CodeBase : file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
grt.helpers.be
    Version de l'assembly : 1.0.0.0
    Version Win32 : 1.0.0.0
    CodeBase : file:///C:/Program%20Files/MySQL/MySQL%20Workbench%205.1%20OSS/grt.helpers.be.DLL
----------------------------------------

************** Débogage JIT **************
Pour activer le débogage juste-à-temps (JIT), le fichier de configuration pour cette
application ou cet ordinateur (machine.config) doit avoir la valeur
jitDebugging définie dans la section system.windows.forms.
L'application doit également être compilée avec le débogage
activé.

Par exemple :

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

Lorsque le débogage juste-à-temps est activé, les exceptions non gérées
seront envoyées au débogueur JIT inscrit sur l'ordinateur
plutôt que d'être gérées par cette boîte de dialogue.

How to repeat:
I'm unable to reproduce the bug !?
[14 Aug 2009 14:00] moi meme
linked mwb file

Attachment: bdd_spot_v4.mwb (application/octet-stream, text), 139.68 KiB.

[14 Aug 2009 14:04] Miguel Solorzano
Thank you for the bug report. I couldn't repeat with model file provided.