Bug #46699 Crash when accessing to a table
Submitted: 13 Aug 2009 15:51 Modified: 13 Aug 2009 20:03
Reporter: Javier Sanchez Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.1.35-community-log OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: innodb

[13 Aug 2009 15:51] Javier Sanchez
Description:
Mysqld process is closed when i try to access to a specific table of a database. Here is the error log:

090813 17:38:57  InnoDB: Error: (1500) Couldn't read the MAX(ID_User) autoinc value from the index (PRIMARY).
090813 17:38:57  InnoDB: Assertion failure in thread 5840 in file .\handler\ha_innodb.cc line 2601
InnoDB: Failing assertion: error == DB_SUCCESS
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
090813 17:38:57 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=16777216
read_buffer_size=262144
max_used_connections=1
max_threads=151
threads_connected=1
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 133305 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x23cf3a8
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
006AE78B    mysqld.exe!???
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 03B07DA8=SHOW TABLE STATUS FROM `users`
thd->thread_id=7
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
InnoDB: Thread 5404 stopped in file .\os\os0sync.c line 271
InnoDB: Thread 5400 stopped in file .\os\os0sync.c line 574

How to repeat:
I don't know because the database was working well before. It seems the error is caused after closing and opening the process.
[13 Aug 2009 20:03] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

Duplicate of bug #44030