Bug #4662 SHOW CREATE TABLE command always fails
Submitted: 21 Jul 2004 0:17 Modified: 26 Jul 2004 22:29
Reporter: Jordan Sparks Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:0.76 OS:Microsoft Windows (WinXP)
Assigned to: Reggie Burnett CPU Architecture:Any

[21 Jul 2004 0:17] Jordan Sparks
Description:
Using ByteFX provider, I ran the query "SHOW CREATE TABLE customer;".  I expected it to return a table with one row and two columns.  Instead, it gave the following error when it reached the DataAdapter.Fill() command:

An unhandled exception of type 'System.ArgumentOutOfRangeException' occurred in system.data.dll.  Additional information: Index and count must refer to a location within the buffer.

How to repeat:
I worked with it for about 8 hours and got the same error message for every single table I tried.  The error happens with both the dataAdapter and the dataReader.   DataReader.HasRows=true and DataReader.FieldCount=2.  So the schema is correct, but it cannot read the data.  It worked fine in version 0.72.  Other users have reported the same bug.
[26 Jul 2004 22:29] Reggie Burnett
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in MySQL.

Additional info:

This is a duplicate of bug #4074.  This has been fixed.