Bug #46579 Columns editor is user unfriendly on Linux
Submitted: 6 Aug 2009 7:06 Modified: 4 Sep 2009 14:14
Reporter: Petr Burian Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.1.16 OS:Linux
Assigned to: CPU Architecture:Any
Tags: columns editor, linux, unfriendly
Triage: Needs Triage: D3 (Medium)

[6 Aug 2009 7:06] Petr Burian
Description:
This is only for Linux version of Workbench.

I have following problems with editor:

 1) Primary key (first row) changes when I typing
 2) Another columns are initially filled with <table_name><colX> string
 3) Can't change position with drag and drop
 4) Clicking to existing column sometimes change it to primary key

Primary I am a linux developer. Before Workbench 5.1 I have to used Windows version. There were no such problems.

How to repeat:
See attached schema.

Ad1) Create new table (will be called "table2") and open it (CTRL+E). Choose columns editor. Now click first row called "idtable2" and delete "table2" so just "id" is left behind. Wait a second and you will see "idtable2" again - annoying magical thing ;)

Ad2) Now when primary key is created, double click next column - a column is added called "table2col" - why? I expect blank line with standard text cursor to write my column's name not some pre-generated name which I must in 100% of cases to erase.

Ad3) Try to change order of columns by left mouse button - standard drag and drop. There is no way how to do it this way. Only solution is using right-clicked context menu. It is of course unfriendly and time consuming

Ad4) Can't simulate it. The problem is really accidental. But have never this problem in Windows version.

Suggested fix:
Make the behaviour of the column editor exactly the same as in Windows version.
[6 Aug 2009 7:06] Petr Burian
MWB to simulate problems

Attachment: column-editor.mwb (application/octet-stream, text), 4.01 KiB.

[6 Aug 2009 9:30] Valeriy Kravchuk
Thank you for the problem report. I tried to repeat all 4 items on Ubuntu and got the followign results:

 1) Primary key (first row) changes when I typing

I can not repeat this.

 2) Another columns are initially filled with <table_name><colX> string

Yes, that is what happens. May be considered a "feature" though :)

 3) Can't change position with drag and drop

This is a real problem.

 4) Clicking to existing column sometimes change it to primary key

This is reported elsewhere aslready (bug #46510).
[6 Aug 2009 18:13] Petr Burian
Ad1) I can't repeat the problem in Kubuntu 9.04 also. I have this bug in Gentoo distro - it will be probably some GTK API issue.
[27 Aug 2009 13:18] Maksym Yehorov
Change of column order with DnD was added.
[27 Aug 2009 15:45] Maksym Yehorov
1) Primary key (first row) changes when I typing
This is fixed.
 2) Another columns are initially filled with <table_name><colX> string
That is how it works, you click on empty line and initial column added, it is name auto-filled. The suggested name is selected, so pressing any alphanumeric key erases suggested name and you are free to enter whatever you like. Format of the suggested name can be changed in Workbench options.
 3) Can't change position with drag and drop
This is added
 4) Clicking to existing column sometimes change it to primary key
This I can not repeat.
[2 Sep 2009 14:55] Johannes Taxacher
this was fixed.
ad 2) this doesn't hurt, does it? as the prefilled value is selected anyway you can just start typing and you'll overwrite the prefilled value with whatever you like
ad 4) in the updated column-editor the option/feature to toggle the PK status by doubleclicking a column has been removed. so no clicks (other thatn on the checkboxes) change the PK state of a column any longer.

fix will be included in 5.1.18
[4 Sep 2009 14:14] Tony Bedford
I've only added a note regarding one of these bugs, as the other are noted in other changelog entries.

A 'change' entry was added to the 5.1.18 changelog:

The Column Editor has been updated to remove the feature whereby a column could be toggled to a primary key by double clicking it. Primary key status can now only be set by selecting the appropriate checkbox in the adjacent Column Details frame.