Bug #46276 From Jira, delete a user causes MySQL to crash
Submitted: 17 Jul 2009 21:21 Modified: 18 Jul 2009 9:03
Reporter: Steve Oliphant Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.1.35 OS:Microsoft Windows
Assigned to:
Tags: assertion failure, crash

[17 Jul 2009 21:21] Steve Oliphant
Description:
I am using the Atlassian product Jira version 3.14.3 with MySQL as the database. Whenever I try to delete a user, MySQL crashes and must be restarted.

Here is the information from the <servername>.log fil.

090717 14:04:56  InnoDB: Started; log sequence number 0 14295417
090717 14:04:56 [Note] Event Scheduler: Loaded 0 events
090717 14:04:56 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.35-community'  socket: ''  port: 3306  MySQL Community Server (GPL)
090717 14:17:49  InnoDB: Assertion failure in thread 508 in file .\row\row0mysql.c line 1534
InnoDB: Failing assertion: index->type & DICT_CLUSTERED
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
090717 14:17:49 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=183500800
read_buffer_size=65536
max_used_connections=2
max_threads=100
threads_connected=2
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 211831 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x223faf18
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
006B5906    mysqld.exe!row_unlock_for_mysql()[row0mysql.c:1534]
006BDB18    mysqld.exe!row_search_for_mysql()[row0sel.c:4090]
006AA670    mysqld.exe!ha_innobase::index_read()[ha_innodb.cc:4412]
0043AB39    mysqld.exe!handler::index_read_map()[handler.h:1390]
00447D56    mysqld.exe!handler::read_range_first()[handler.cc:4176]
00445E6C    mysqld.exe!handler::read_multi_range_first()[handler.cc:4050]
004D7A4B    mysqld.exe!QUICK_RANGE_SELECT::get_next()[opt_range.cc:8468]
004E9261    mysqld.exe!rr_quick()[records.cc:313]
0053C74D    mysqld.exe!mysql_delete()[sql_delete.cc:289]
00556878    mysqld.exe!mysql_execute_command()[sql_parse.cc:3273]
0055A8C3    mysqld.exe!mysql_parse()[sql_parse.cc:5933]
0055B3B3    mysqld.exe!dispatch_command()[sql_parse.cc:1218]
0055C1B7    mysqld.exe!do_command()[sql_parse.cc:861]
005DF511    mysqld.exe!handle_one_connection()[sql_connect.cc:1115]
0064588B    mysqld.exe!pthread_start()[my_winthread.c:85]
0072ADD3    mysqld.exe!_callthreadstart()[thread.c:293]
FCB0E900    
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 22445D10=DELETE FROM propertyentry WHERE ENTITY_NAME='OSUser' AND ENTITY_ID=10063 AND PROPERTY_KEY='fullName'
thd->thread_id=1
thd->killed=NOT_KILLED
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

I am using the most current jdbc connector as well. Version mysql-connector-java-5.1.8-bin.jar.

How to repeat:
Just restart the database and try to delete a user.
[18 Jul 2009 9:03] Valerii Kravchuk
This is a duplicate of bug #45357 that should be fixed in 5.1.37. Please, check.