Bug #46085 Valgrind warnings (InnoDB code) in test rpl_trigger
Submitted: 9 Jul 2009 13:49 Modified: 9 Sep 2009 13:27
Reporter: Guilhem Bichot Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.4.2 (summit), mysql-trunk OS:Linux
Assigned to: CPU Architecture:Any
Triage: Triaged: D2 (Serious)

[9 Jul 2009 13:49] Guilhem Bichot
Description:
With 5.1-performance-version, latest revision:
mikael@mysql.com-20090702155353-v2xbu1tlct7epb95

./mtr rpl_trigger --valgrind
I get, on top of BUG#46081 and BUG#45630, this one:

==31105==    by 0x97406A: mem_heap_create_block (mem0mem.c:362)
==31105==    by 0x9733A4: mem_heap_create_func (mem0mem.ic:421)
==31105==    by 0x973523: mem_alloc_func (mem0mem.ic:511)
==31105==    by 0x9A8B4E: thr_local_create (thr0loc.c:166)
==31105==    by 0x9A8A29: thr_local_get (thr0loc.c:78)
==31105==    by 0x9A8B08: thr_local_get_in_ibuf_field (thr0loc.c:146)
==31105==    by 0x95E593: ibuf_enter (ibuf0ibuf.c:251)
==31105==    by 0x95E95F: ibuf_data_init_for_space (ibuf0ibuf.c:487)
==31105==    by 0x9511C7: fil_ibuf_init_at_db_start (fil0fil.c:1488)
==31105==    by 0x95E79B: ibuf_init_at_db_start (ibuf0ibuf.c:402)
==31105==    by 0x9C21FE: dict_boot (dict0boot.c:384)
==31105==    by 0x9C22C0: dict_create (dict0boot.c:422)
==31105==    by 0x9A5A59: innobase_start_or_create_for_mysql (srv0start.c:1502)
==31105==    by 0x9293F1: _ZL13innobase_initPv (ha_innodb.cc:1785)
==31105== 
==31105== 
==31105== 1,753,184 bytes in 120 blocks are still reachable in loss record 8 of 8
==31105==    at 0x4C265AE: malloc (vg_replace_malloc.c:207)
==31105==    by 0x974DD5: mem_area_alloc (mem0pool.c:334)
==31105==    by 0x97406A: mem_heap_create_block (mem0mem.c:362)
==31105==    by 0x9733A4: mem_heap_create_func (mem0mem.ic:421)
==31105==    by 0x973523: mem_alloc_func (mem0mem.ic:511)
==31105==    by 0x9A0202: srv_init (srv0srv.c:963)
==31105==    by 0x9A100B: srv_boot (srv0srv.c:1511)
==31105==    by 0x9A52E4: innobase_start_or_create_for_mysql (srv0start.c:1209)
==31105==    by 0x9293F1: _ZL13innobase_initPv (ha_innodb.cc:1785)
==31105==    by 0x7FFEEE: ha_initialize_handlerton(st_plugin_int*) (handler.cc:433)
==31105==    by 0x8BAC3D: _ZL17plugin_initializeP13st_plugin_int (sql_plugin.cc:1003)
==31105==    by 0x8BE8FD: plugin_init(int*, char**, int) (sql_plugin.cc:1216)
==31105==    by 0x6B9869: _ZL22init_server_componentsv (mysqld.cc:3973)
==31105==    by 0x6BA308: main (mysqld.cc:4445)

I don't get this with 5.1-main, so maybe this is summit-specific.
This isn't visible in pushbuild2 for 5.1-performance-version, likely because the testsuite aborts before rpl_trigger in mixed mode due to errors in zlib. But it is visible in the tree which contains the merge of summit into azalea, and not visible in azalea, so this really looks summit-specific.
I'm using valgrind-3.3.1-Debian.

How to repeat:
run the test.
[13 Aug 2009 12:38] Guilhem Bichot
This is now visible in mysql-trunk. See also BUG#46656 and BUG#45592
[9 Sep 2009 13:27] Guilhem Bichot
duplicate of BUG#46656.