Bug #45958 error while restoring mysqldump
Submitted: 6 Jul 2009 6:22 Modified: 10 Sep 2009 19:19
Reporter: Yogesh Malik Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: mysqldump Command-line Client Severity:S2 (Serious)
Version:5.1.36 OS:Linux
Assigned to: CPU Architecture:Any

[6 Jul 2009 6:22] Yogesh Malik
Description:
I am restoring database on mysql version 5.1.36 from dump taken from mysql version 5.0.67.
Database is around 70 GB in size.
After restoring 50% data restore exist with following error:
ERROR at line 37477: Unknown command '\"'.

How to repeat:
take a dump and restore.
[6 Jul 2009 6:42] Valeriy Kravchuk
Thank you for the problem report. Can you, please, send that line 37477 (and a couple of lines before and after it) from the dump?
[5 Aug 2009 11:25] sudha kasth
We are also facing the same problem. Dump taken from MySQL-5.1.30 and populated on MySQL-5.1.36.

It is a HTML content escaped with '\'.

Please suggest us to fix this issue.
[5 Aug 2009 11:34] sudha kasth
One insert query is at that line. It is 1 MB size. So I could not share with you.
[6 Aug 2009 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[7 Aug 2009 6:38] Valeriy Kravchuk
Even 1M Insert can be taken out of the dump, compressed and attached to the report  (as private file if you want) or uploaded to our ftp server. We need a repeatable test case to be able to fix the bug.
[9 Aug 2009 4:26] Yogesh Malik
this is the line

ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''<?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?><rtml version=\"1.' at line 1
[10 Aug 2009 19:19] Sveta Smirnova
Thank you for the feedback.

Please also provide command line you use when invoke mysqldump. Please also check if max_allowed_packet large enough.
[10 Sep 2009 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".